# CVE-2025-66479: Anthropic Sandbox Runtime Incorrectly Implemented Network Sandboxing

> Sandboxed code can bypass network restrictions if no allowed domains are configured, allowing unauthorized network access.

- **Severity:** Low 1.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-9gqj-5w7c-vx47

## What is CVE-2025-66479?

CVE-2025-66479 is a low-severity vulnerability in anthropic-experimental sandbox-runtime, published on 4 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Anthropic Sandbox Runtime is a lightweight sandboxing tool for enforcing filesystem and network restrictions on arbitrary processes at the OS level, without requiring a container. Prior to 0.0.16, due to a bug in sandboxing logic, sandbox-runtime did not properly enforce a network sandbox if the sandbox policy did not configure any allowed domains. This could allow sandboxed code to make network requests outside of the sandbox. A patch for this was released in v0.0.16.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2025-66479?

2 open source packages ship an affected version, including @anthropic-ai/sandbox-runtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/sandbox-runtime` | npm | All versions | 0.0.16 |
| `@anthropic-ai/sandbox-runtime` | npm | All versions | 0.0.16 |

## How do I fix CVE-2025-66479?

Upgrade @anthropic-ai/sandbox-runtime to 0.0.16 or later.

## Is CVE-2025-66479 being exploited?

There is no known exploitation of CVE-2025-66479 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66479 and fix it if it is affected.

What it is: CVE-2025-66479 is a low-severity vulnerability in anthropic-experimental sandbox-runtime, published on 4 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66479 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/sandbox-runtime (npm): affected all versions; fixed in 0.0.16
- @anthropic-ai/sandbox-runtime (npm): affected all versions; fixed in 0.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66479/ (Markdown: https://insights.sbomify.com/CVE-2025-66479/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66479
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66479
- OSV: https://osv.dev/vulnerability/CVE-2025-66479

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66479/
Summaries are generated and may contain mistakes; the official description above is the record.
