# CVE-2025-66491: Traefik has Inverted TLS Verification Logic in its ingress-nginx Provider

> Traefik's ingress-nginx provider incorrectly disables TLS verification when enabled, allowing man-in-the-middle attacks against HTTPS backends.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-7vww-mvcr-x6vj, GO-2025-4205, MINI-2gpr-f46c-76fm, MINI-34hh-5w9m-w3j8

## What is CVE-2025-66491?

CVE-2025-66491 is a medium-severity vulnerability in Traefik Traefik, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Traefik is an HTTP reverse proxy and load balancer. Versions 3.5.0 through 3.6.2 have inverted TLS verification logic in the nginx.ingress.kubernetes.io/proxy-ssl-verify annotation. Setting the annotation to "on" (intending to enable backend TLS certificate verification) actually disables verification, allowing man-in-the-middle attacks against HTTPS backends when operators believe they are protected. This issue is fixed in version 3.6.3.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-66491?

5 open source packages ship an affected version, including github.com/traefik/traefik/v3, github.com/traefik/traefik and github.com/traefik/traefik/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik/v3` | Go | From 3.5.0 | 3.6.3 |
| `github.com/traefik/traefik/v3` | Go | From 3.5.0 | 3.6.3 |
| `github.com/traefik/traefik/v3` | Go | From 3.5.0 | 3.6.3 |
| `github.com/traefik/traefik` | Go | All versions | None |
| `github.com/traefik/traefik/v2` | Go | All versions | None |

Products: Traefik Traefik.

## How do I fix CVE-2025-66491?

Upgrade github.com/traefik/traefik/v3 to 3.6.3 or later.

## Is CVE-2025-66491 being exploited?

There is no known exploitation of CVE-2025-66491 in the wild and no public exploit code.

## Other vulnerabilities in Traefik Traefik

- [CVE-2024-45410](https://insights.sbomify.com/CVE-2024-45410/): HTTP client can remove the X-Forwarded headers in Traefik (critical 9.8)
- [CVE-2026-88877](https://insights.sbomify.com/CVE-2026-88877/): Traefik v3.7.0 Authentication Bypass via from-to-www-redirect (critical 9.3)
- [CVE-2026-85595](https://insights.sbomify.com/CVE-2026-85595/): Traefik before v2.11.55 and v3.0.0 through v3.7.10 Authentication Bypass via digestAuth (critical 9.3)
- [CVE-2026-88007](https://insights.sbomify.com/CVE-2026-88007/): Traefik HTTP/3 Backend NTLM Connection Reuse (critical 9.1)
- [CVE-2026-88009](https://insights.sbomify.com/CVE-2026-88009/): Traefik: Rootless HTTP/1 request-target routes as "/" but is forwarded verbatim, bypassing path-scoped routing, middleware guards and access logging (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66491 and fix it if it is affected.

What it is: CVE-2025-66491 is a medium-severity vulnerability in Traefik Traefik, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66491 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/traefik/traefik/v3 (Go): affected from 3.5.0; fixed in 3.6.3
- github.com/traefik/traefik/v3 (Go): affected from 3.5.0; fixed in 3.6.3
- github.com/traefik/traefik/v3 (Go): affected from 3.5.0; fixed in 3.6.3
- github.com/traefik/traefik (Go): affected all versions; no fix listed
- github.com/traefik/traefik/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66491/ (Markdown: https://insights.sbomify.com/CVE-2025-66491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66491
- OSV: https://osv.dev/vulnerability/CVE-2025-66491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66491/
Summaries are generated and may contain mistakes; the official description above is the record.
