# CVE-2025-66506: Fulcio allocates excessive memory during token parsing

> Attackers can cause excessive memory allocation and denial of service in Fulcio by sending OIDC tokens with many period characters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** CLEANSTART-2026-KK01897, CLEANSTART-2026-TG34900, DEBIAN-CVE-2025-66506, GHSA-f83f-xpx7-ffpw, GO-2025-4193, MINI-22r3-82g9-3qq6, MINI-4mw6-5g7w-vwhq, MINI-56pw-3j58-r3f7, MINI-5xp8-9wjx-xh4r, MINI-6m5x-8p33-644h, MINI-6q37-vch2-7532, MINI-78vw-w53q-mwv7, MINI-7fvm-hrjm-7p3x, MINI-95vh-j973-2gw5, MINI-cfw4-843h-w9v3, MINI-cq6f-r5hh-798r, MINI-f24h-4wj4-9g33, MINI-ghm2-8x27-8vjx, MINI-ghr6-fhj7-w4h7, MINI-ghrm-pmxm-88v6, MINI-gv6g-fvm8-q8cf, MINI-hxf6-4ph4-gpxx, MINI-j6j4-v9gx-qw6h, MINI-mhrj-68j6-8jwc, MINI-mvf2-r6ph-674f, MINI-pmw6-jv27-qjmq, MINI-q7x7-9p8j-5g6m, MINI-vr2m-fcmr-jh6r, MINI-wv6c-h2gj-87p2, MINI-x644-hq54-q5r4, MINI-x9xv-fc8w-x4q5, MINI-xpf7-h8f2-2mg2, UBUNTU-CVE-2025-66506

## What is CVE-2025-66506?

CVE-2025-66506 is a high-severity denial of service vulnerability in sigstore fulcio, published on 4 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fulcio is a free-to-use certificate authority for issuing code signing certificates for an OpenID Connect (OIDC) identity. Prior to 1.8.3, function identity.extractIssuerURL splits (via a call to strings.Split) its argument (which is untrusted data) on periods. As a result, in the face of a malicious request with an (invalid) OIDC identity token in the payload containing many period characters, a call to extractIssuerURL incurs allocations to the tune of O(n) bytes (where n stands for the length of the function's argument), with a constant factor of about 16. This vulnerability is fixed in 1.8.3.

Weakness: CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2025-66506?

3 open source packages ship an affected version, including github.com/sigstore/fulcio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/fulcio` | Go | All versions | 1.8.3 |
| `github.com/sigstore/fulcio` | Go | All versions | 1.8.3 |
| `github.com/sigstore/fulcio` | Go | All versions | 1.8.3 |

Products: Linuxfoundation Fulcio.

## How do I fix CVE-2025-66506?

Upgrade github.com/sigstore/fulcio to 1.8.3 or later.

## Is CVE-2025-66506 being exploited?

There is no known exploitation of CVE-2025-66506 in the wild and no public exploit code.

## Other vulnerabilities in sigstore fulcio

- [CVE-2026-22772](https://insights.sbomify.com/CVE-2026-22772/): Fulcio vulnerable to Server-Side Request Forgery (SSRF) via MetaIssuer Regex Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66506 and fix it if it is affected.

What it is: CVE-2025-66506 is a high-severity denial of service vulnerability in sigstore fulcio, published on 4 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66506 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sigstore/fulcio (Go): affected all versions; fixed in 1.8.3
- github.com/sigstore/fulcio (Go): affected all versions; fixed in 1.8.3
- github.com/sigstore/fulcio (Go): affected all versions; fixed in 1.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66506/ (Markdown: https://insights.sbomify.com/CVE-2025-66506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66506
- OSV: https://osv.dev/vulnerability/CVE-2025-66506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66506/
Summaries are generated and may contain mistakes; the official description above is the record.
