CVE-2025-66507 1Panel – CAPTCHA Bypass via Client-Controlled Flag
Unauthenticated attackers can bypass CAPTCHA verification in 1Panel by manipulating a client-controlled parameter, facilitating automated login attempts and account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66507?
CVE-2025-66507 is a high-severity vulnerability in 1Panel-dev 1Panel, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
1Panel is an open-source, web-based control panel for Linux server management. Versions 2.0.13 and below allow an unauthenticated attacker to disable CAPTCHA verification by abusing a client-controlled parameter. Because the server previously trusted this value without proper validation, CAPTCHA protections can be bypassed, enabling automated login attempts and significantly increasing the risk of account takeover (ATO). This issue is fixed in version 2.0.14.
Which versions are affected by CVE-2025-66507?
6 open source packages ship an affected version, including github.com/1Panel-dev/1Panel and github.com/1Panel-dev/1Panel/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/1Panel-dev/1Panel Go | All versions | 2.0.14 |
github.com/1Panel-dev/1Panel Go | All versions | 2.0.14 |
github.com/1Panel-dev/1Panel Go | All versions | 2.0.14+incompatible |
github.com/1Panel-dev/1Panel/core Go | All versions | 0.0.0-20251128030527-ac43f00273be |
github.com/1Panel-dev/1Panel/core Go | All versions | 0.0.0-20251128030527-ac43f00273be |
github.com/1Panel-dev/1Panel/core Go | All versions | 0.0.0-20251128030527-ac43f00273be |
Products include Fit2cloud 1panel.
How do I fix CVE-2025-66507?
Upgrade github.com/1Panel-dev/1Panel to a fixed version for your release line: 2.0.14 or 2.0.14+incompatible.
Is CVE-2025-66507 being exploited?
There is no known exploitation of CVE-2025-66507 in the wild and no public exploit code.
Other vulnerabilities in 1Panel-dev 1Panel
- CVE-2024-39911 1Panel SQL injection
- CVE-2024-39907 a sqlinjection in 1Panel
- CVE-2025-56413 Command injection in n/a
- CVE-2025-54424 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution
- CVE-2023-39964 1Panel O&M management panel has a background arbitrary file reading vulnerability
Sources
Also known as GHSA-qmg5-v42x-qqhq, GO-2025-4209.