# CVE-2025-66507: 1Panel – CAPTCHA Bypass via Client-Controlled Flag

> Unauthenticated attackers can bypass CAPTCHA verification in 1Panel by manipulating a client-controlled parameter, facilitating automated login attempts and account takeover.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-qmg5-v42x-qqhq, GO-2025-4209

## What is CVE-2025-66507?

CVE-2025-66507 is a high-severity vulnerability in 1Panel-dev 1Panel, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

1Panel is an open-source, web-based control panel for Linux server management. Versions 2.0.13 and below allow an unauthenticated attacker to disable CAPTCHA verification by abusing a client-controlled parameter. Because the server previously trusted this value without proper validation, CAPTCHA protections can be bypassed, enabling automated login attempts and significantly increasing the risk of account takeover (ATO). This issue is fixed in version 2.0.14.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision), CWE-602 (Client-Side Enforcement of Server-Side Security), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-66507?

6 open source packages ship an affected version, including github.com/1Panel-dev/1Panel and github.com/1Panel-dev/1Panel/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 2.0.14 |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 2.0.14 |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 2.0.14+incompatible |
| `github.com/1Panel-dev/1Panel/core` | Go | All versions | 0.0.0-20251128030527-ac43f00273be |
| `github.com/1Panel-dev/1Panel/core` | Go | All versions | 0.0.0-20251128030527-ac43f00273be |
| `github.com/1Panel-dev/1Panel/core` | Go | All versions | 0.0.0-20251128030527-ac43f00273be |

Products: Fit2cloud 1panel.

## How do I fix CVE-2025-66507?

Upgrade github.com/1Panel-dev/1Panel to a fixed version for your release line: 2.0.14 or 2.0.14+incompatible.

## Is CVE-2025-66507 being exploited?

There is no known exploitation of CVE-2025-66507 in the wild and no public exploit code.

## Other vulnerabilities in 1Panel-dev 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-54424](https://insights.sbomify.com/CVE-2025-54424/): 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution (high 8.1)
- [CVE-2023-39964](https://insights.sbomify.com/CVE-2023-39964/): 1Panel O&M management panel has a background arbitrary file reading vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66507 and fix it if it is affected.

What it is: CVE-2025-66507 is a high-severity vulnerability in 1Panel-dev 1Panel, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66507 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 2.0.14
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 2.0.14
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 2.0.14+incompatible
- github.com/1Panel-dev/1Panel/core (Go): affected all versions; fixed in 0.0.0-20251128030527-ac43f00273be
- github.com/1Panel-dev/1Panel/core (Go): affected all versions; fixed in 0.0.0-20251128030527-ac43f00273be
- github.com/1Panel-dev/1Panel/core (Go): affected all versions; fixed in 0.0.0-20251128030527-ac43f00273be

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66507/ (Markdown: https://insights.sbomify.com/CVE-2025-66507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66507
- OSV: https://osv.dev/vulnerability/CVE-2025-66507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66507/
Summaries are generated and may contain mistakes; the official description above is the record.
