# CVE-2025-66515: Nextcloud Approval app allows users to request approval for other users file

> Authenticated users can modify approval status of other users' files without proper authorization, requiring an upgrade to the Nextcloud Approval app.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-q26g-fmjq-x5g5

## What is CVE-2025-66515?

CVE-2025-66515 is a low-severity missing authorization vulnerability in nextcloud security-advisories, published on 5 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The Nextcloud Approval app allows approval or disapproval of files in the sidebar. Prior to 1.3.1 and 2.5.0, an authenticated user listed as a requester in a workflow can set another user’s file into the “pending approval” without access to the file by using the numeric file id. This vulnerability is fixed in 1.3.1 and 2.5.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-66515?

It affects 1 product.


Products: Nextcloud Approval.

## How do I fix CVE-2025-66515?

No fix has been published for CVE-2025-66515 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66515 being exploited?

There is no known exploitation of CVE-2025-66515 in the wild and no public exploit code.

## Other vulnerabilities in nextcloud security-advisories

- [CVE-2026-45275](https://insights.sbomify.com/CVE-2026-45275/): Nextcloud: Authorization bypass in approval feature allows unauthorized file sharing with approvers (medium 6.5)
- [CVE-2026-45277](https://insights.sbomify.com/CVE-2026-45277/): Nextcloud: Information disclosure in Nextcloud Approval app via fileId parameter reveals workflow associations (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66515 and fix it if it is affected.

What it is: CVE-2025-66515 is a low-severity missing authorization vulnerability in nextcloud security-advisories, published on 5 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66515 in the wild and no public exploit code.

Affected product: nextcloud security-advisories. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66515/ (Markdown: https://insights.sbomify.com/CVE-2025-66515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66515
- OSV: https://osv.dev/vulnerability/CVE-2025-66515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66515/
Summaries are generated and may contain mistakes; the official description above is the record.
