CVE-2025-66516 Apache Tika has XXE vulnerability
Attackers can exploit XML External Entity injection in Apache Tika via crafted PDFs to read sensitive data or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66516?
CVE-2025-66516 is a high-severity vulnerability in Apache Tika PDF parser module, published on 4 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF.
This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways.
First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable.
Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
Weakness: CWE-611
Which versions are affected by CVE-2025-66516?
6 open source packages ship an affected version, including org.apache.tika:tika-parser-pdf-module, org.apache.tika:tika-core and org.apache.tika:tika-parsers. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tika:tika-parser-pdf-module Maven | From 2.0.0 | 3.2.2 |
org.apache.tika:tika-parser-pdf-module Maven | From 2.0.0 | 3.2.2 |
org.apache.tika:tika-core Maven | From 1.13 | 3.2.2 |
org.apache.tika:tika-core Maven | From 1.13 | 3.2.2 |
org.apache.tika:tika-parsers Maven | From 1.13 | 2.0.0 |
org.apache.tika:tika-parsers Maven | From 1.13 | 2.0.0 |
Products include Apache Tika.
How do I fix CVE-2025-66516?
Upgrade org.apache.tika:tika-parser-pdf-module to 3.2.2 or later.
Is CVE-2025-66516 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66516 exists.
Public exploit code: 1 Metasploit module, 1 Nuclei template and 3 proofs of concept on GitHub.
Other vulnerabilities in Apache Tika PDF parser module
- CVE-2019-10088 Allocation of Resources Without Limits or Throttling in Apache Tika
- CVE-2025-54988 Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA
- CVE-2018-1335 Command injection in org.apache.tika:tika-core
- CVE-2019-10094 Allocation of Resources Without Limits or Throttling in Apache Tika
- CVE-2016-4434 Apache Tika does not properly initialize the XML parser or choose handlers
Sources
Also known as CLEANSTART-2026-HF44570, CLEANSTART-2026-TY92460, DEBIAN-CVE-2025-66516, GHSA-f58c-gq56-vjjf, MINI-4x4r-vj96-gqmj, MINI-544p-mwgc-mh5g and 11 more.