CVE-2025-66518 Apache Kyuubi: Unauthorized directory access due to missing path normalization
Attackers can bypass directory restrictions to access unauthorized local files on Apache Kyuubi servers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-66518?
CVE-2025-66518 is a high-severity path traversal vulnerability in Apache Kyuubi, published on 5 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config.
This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2.
Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.
Which versions are affected by CVE-2025-66518?
2 open source packages ship an affected version, including org.apache.kyuubi:kyuubi-server_2.12. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kyuubi:kyuubi-server_2.12 Maven | From 1.6.0 | 1.10.3 |
org.apache.kyuubi:kyuubi-server_2.12 Maven | From 1.6.0 | 1.10.3 |
Products include Apache Kyuubi.
How do I fix CVE-2025-66518?
Upgrade org.apache.kyuubi:kyuubi-server_2.12 to 1.10.3 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-66518 being exploited?
There is no known exploitation of CVE-2025-66518 in the wild and no public exploit code.
Other vulnerabilities in Apache Kyuubi
Sources
Also known as GHSA-f8r6-6222-9pvc.