# CVE-2025-66518: Apache Kyuubi: Unauthorized directory access due to missing path normalization

> Attackers can bypass directory restrictions to access unauthorized local files on Apache Kyuubi servers.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** GHSA-f8r6-6222-9pvc

## What is CVE-2025-66518?

CVE-2025-66518 is a high-severity path traversal vulnerability in Apache Kyuubi, published on 5 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config.

This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2.

Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-27 (Path Traversal: 'dir/../../filename')

## Which versions are affected by CVE-2025-66518?

2 open source packages ship an affected version, including org.apache.kyuubi:kyuubi-server_2.12. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kyuubi:kyuubi-server_2.12` | Maven | From 1.6.0 | 1.10.3 |
| `org.apache.kyuubi:kyuubi-server_2.12` | Maven | From 1.6.0 | 1.10.3 |

Products: Apache Kyuubi.

## How do I fix CVE-2025-66518?

Upgrade org.apache.kyuubi:kyuubi-server_2.12 to 1.10.3 or later.

## Is CVE-2025-66518 being exploited?

There is no known exploitation of CVE-2025-66518 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kyuubi

- [CVE-2026-52680](https://insights.sbomify.com/CVE-2026-52680/): Apache Kyuubi: REST batch multipart upload path traversal allows controlled file write (critical 9.8)
- [CVE-2026-62391](https://insights.sbomify.com/CVE-2026-62391/): Apache Kyuubi: kyuubi.session.local.dir.allow.list bypass via unprefixed Spark file-conf aliases (high 8.1)
- [CVE-2026-23904](https://insights.sbomify.com/CVE-2026-23904/): Apache Kyuubi: Unrestricted access via Kyuubi engine-ui proxy (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66518 and fix it if it is affected.

What it is: CVE-2025-66518 is a high-severity path traversal vulnerability in Apache Kyuubi, published on 5 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-66518 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kyuubi:kyuubi-server_2.12 (Maven): affected from 1.6.0; fixed in 1.10.3
- org.apache.kyuubi:kyuubi-server_2.12 (Maven): affected from 1.6.0; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66518/ (Markdown: https://insights.sbomify.com/CVE-2025-66518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66518
- OSV: https://osv.dev/vulnerability/CVE-2025-66518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66518/
Summaries are generated and may contain mistakes; the official description above is the record.
