# CVE-2025-66524: Apache NiFi: Deserialization of Untrusted Data in GetAsanaObject Processor

> Attackers with cache access can execute code via unsafe Java deserialization in the GetAsanaObject processor of Apache NiFi.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/AU:Y/R:U/V:C/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-nifi-2025-66524, CLEANSTART-2026-KF29618, CLEANSTART-2026-UW09726, CLEANSTART-2026-WE49283, GHSA-v4p2-2w39-mhrj

## What is CVE-2025-66524?

CVE-2025-66524 is a high-severity unsafe deserialization vulnerability in Apache Nifi, published on 19 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache NiFi 1.20.0 through 2.6.0 include the GetAsanaObject Processor, which requires integration with a configurable Distribute Map Cache Client Service for storing and retrieving state information. The GetAsanaObject Processor used generic Java Object serialization and deserialization without filtering. Unfiltered Java object deserialization does not provide protection against crafted state information stored in the cache server configured for GetAsanaObject. Exploitation requires an Apache NiFi system running with the GetAsanaObject Processor, and direct access to the configured cache server. Upgrading to Apache NiFi 2.7.0 is the recommended mitigation, which replaces Java Object serialization with JSON serialization. Removing the GetAsanaObject Processor located in the nifi-asana-processors-nar bundle also prevents exploitation.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-66524?

3 open source packages ship an affected version, including org.apache.nifi:nifi-asana-processors and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-asana-processors` | Maven | From 1.20.0 | 2.7.0 |
| `org.apache.nifi:nifi-asana-processors` | Maven | From 1.20.0 | 2.7.0 |
| `nifi` | Bitnami | From 1.20.0 | 2.7.0 |

Products: Apache Nifi.

## How do I fix CVE-2025-66524?

Upgrade org.apache.nifi:nifi-asana-processors to 2.7.0 or later.

## Is CVE-2025-66524 being exploited?

There is no known exploitation of CVE-2025-66524 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66524 and fix it if it is affected.

What it is: CVE-2025-66524 is a high-severity unsafe deserialization vulnerability in Apache Nifi, published on 19 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66524 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-asana-processors (Maven): affected from 1.20.0; fixed in 2.7.0
- org.apache.nifi:nifi-asana-processors (Maven): affected from 1.20.0; fixed in 2.7.0
- nifi (Bitnami): affected from 1.20.0; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66524/ (Markdown: https://insights.sbomify.com/CVE-2025-66524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66524
- OSV: https://osv.dev/vulnerability/CVE-2025-66524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66524/
Summaries are generated and may contain mistakes; the official description above is the record.
