CVE-2025-66554 Nextcloud Contacts vulnerable to Stored XSS in contacts app via organisation and title field
A malicious user can inject CSS via contact fields, bypassing some protections, requiring Nextcloud administrators to upgrade the Contacts app.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-66554?
CVE-2025-66554 is a low-severity cross-site scripting vulnerability in nextcloud security-advisories, published on 5 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Contacts app for Nextcloud easily syncs contacts from various devices with your Nextcloud and allows editing. Prior to 5.5.4, 6.0.6, and 7.2.5, a malicious user was able to modify their organisation and title field to load additional CSS files. Javascript and other options were correctly blocked by the content security policy of the Nextcloud Server code. This vulnerability is fixed in 5.5.4, 6.0.6, and 7.2.5.
Weakness: CWE-79
Which versions are affected by CVE-2025-66554?
It affects 1 product.
Products include Nextcloud Contacts.
How do I fix CVE-2025-66554?
No fix has been published for CVE-2025-66554 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-66554 being exploited?
There is no known exploitation of CVE-2025-66554 in the wild and no public exploit code.
Other vulnerabilities in nextcloud security-advisories
Sources
Also known as GHSA-9v78-cpfc-v6h2.