# CVE-2025-66558: Nextcloud Twofactor WebAuthn app was updated based on public key

> An attacker can remove a victim's WebAuthn 2FA device by guessing a random string, forcing re-registration, due to missing ownership checks.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-fr8x-mvjg-wf9q

## What is CVE-2025-66558?

CVE-2025-66558 is a low-severity missing authorization vulnerability in nextcloud security-advisories, published on 5 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nextcloud Twofactor WebAuthn is the WebAuthn Two-Factor Provider for Nextcloud. Prior to 1.4.2 and 2.4.1, a missing ownership check allowed an attack to take-away a 2FA webauthn device when correctly guessing a 80-128 character long random string of letters, numbers and symbols. The victim would then be prompted to register a new device on the next login. The attacker can not authenticate as the victim. This vulnerability is fixed in 1.4.2 and 2.4.1.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-66558?

It affects 1 product.


Products: Nextcloud Two-Factor Webauthn.

## How do I fix CVE-2025-66558?

No fix has been published for CVE-2025-66558 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66558 being exploited?

There is no known exploitation of CVE-2025-66558 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66558 and fix it if it is affected.

What it is: CVE-2025-66558 is a low-severity missing authorization vulnerability in nextcloud security-advisories, published on 5 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66558 in the wild and no public exploit code.

Affected product: nextcloud security-advisories. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66558/ (Markdown: https://insights.sbomify.com/CVE-2025-66558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66558
- OSV: https://osv.dev/vulnerability/CVE-2025-66558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66558/
Summaries are generated and may contain mistakes; the official description above is the record.
