# CVE-2025-66560: Quarkus REST has potential worker thread starvation when HTTP connection is closed while waiting to write

> Attackers can cause worker thread starvation and application unavailability by closing HTTP connections during response writes in Quarkus REST.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 7 Jan 2026
- **Also known as:** CLEANSTART-2026-NX85798, CLEANSTART-2026-PA41665, CLEANSTART-2026-VG40041, GHSA-5rfx-cp42-p624, MINI-chq2-xrqx-chq6, MINI-rqhh-7vg4-72cj

## What is CVE-2025-66560?

CVE-2025-66560 is a medium-severity denial of service vulnerability in quarkusio quarkus, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Quarkus is a Cloud Native, (Linux) Container First framework for writing Java applications. Prior to versions 3.31.0, 3.27.2, and 3.20.5, a vulnerability exists in the HTTP layer of Quarkus REST related to response handling. When a response is being written, the framework waits for previously written response chunks to be fully transmitted before proceeding. If the client connection is dropped during this waiting period, the associated worker thread is never released and becomes permanently blocked. Under sustained or repeated occurrences, this can exhaust the available worker threads, leading to degraded performance, or complete unavailability of the application. This issue has been patched in versions 3.31.0, 3.27.2, and 3.20.5. A workaround involves implementing a health check that monitors the status and saturation of the worker thread pool to detect abnormal thread retention early.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-66560?

6 open source packages ship an affected version, including io.quarkus:quarkus-rest. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.quarkus:quarkus-rest` | Maven | All versions | 3.20.5 |
| `io.quarkus:quarkus-rest` | Maven | All versions | 3.20.5 |
| `io.quarkus:quarkus-rest` | Maven | From 3.21.0 | 3.27.2 |
| `io.quarkus:quarkus-rest` | Maven | From 3.21.0 | 3.27.2 |
| `io.quarkus:quarkus-rest` | Maven | From 3.30.0 | 3.31.0 |
| `io.quarkus:quarkus-rest` | Maven | From 3.30.0 | 3.31.0 |

Products: Quarkus Quarkus.

## How do I fix CVE-2025-66560?

Upgrade io.quarkus:quarkus-rest to a fixed version for your release line: 3.20.5, 3.27.2 or 3.31.0.

## Is CVE-2025-66560 being exploited?

There is no known exploitation of CVE-2025-66560 in the wild and no public exploit code.

## Other vulnerabilities in quarkusio quarkus

- [CVE-2022-4116](https://insights.sbomify.com/CVE-2022-4116/): Code injection in quarkus dev ui config editor (critical 9.8)
- [CVE-2022-2466](https://insights.sbomify.com/CVE-2022-2466/): Quarkus does not terminate HTTP requests header context (critical 9.8)
- [CVE-2024-12225](https://insights.sbomify.com/CVE-2024-12225/): Io.quarkus:quarkus-security-webauthn: quarkus webauthn unexpected authentication bypass (critical 9.1)
- [CVE-2026-39852](https://insights.sbomify.com/CVE-2026-39852/): Quarkus authorization bypass via semicolon path normalization inconsistency (high 8.8)
- [CVE-2022-0981](https://insights.sbomify.com/CVE-2022-0981/): Privilege escalation in quarkus (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66560 and fix it if it is affected.

What it is: CVE-2025-66560 is a medium-severity denial of service vulnerability in quarkusio quarkus, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66560 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.quarkus:quarkus-rest (Maven): affected all versions; fixed in 3.20.5
- io.quarkus:quarkus-rest (Maven): affected all versions; fixed in 3.20.5
- io.quarkus:quarkus-rest (Maven): affected from 3.21.0; fixed in 3.27.2
- io.quarkus:quarkus-rest (Maven): affected from 3.21.0; fixed in 3.27.2
- io.quarkus:quarkus-rest (Maven): affected from 3.30.0; fixed in 3.31.0
- io.quarkus:quarkus-rest (Maven): affected from 3.30.0; fixed in 3.31.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66560/ (Markdown: https://insights.sbomify.com/CVE-2025-66560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66560
- OSV: https://osv.dev/vulnerability/CVE-2025-66560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66560/
Summaries are generated and may contain mistakes; the official description above is the record.
