{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66561 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-66561 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-66561 is a high-severity cross-site scripting vulnerability in Syslifters sysreptor, published on 4 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-66561 and fix it if it is affected.\n\nWhat it is: CVE-2025-66561 is a high-severity cross-site scripting vulnerability in Syslifters sysreptor, published on 4 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-66561 in the wild and no public exploit code.\n\nAffected product: Syslifters sysreptor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66561/ (Markdown: https://insights.sbomify.com/CVE-2025-66561/index.md)","id":"CVE-2025-66561","markdown":"https://insights.sbomify.com/CVE-2025-66561/index.md","name":"CVE-2025-66561","record":{"aliases":["GHSA-64vw-v5c4-mgvm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"pentest reporting platform","requires_auth":"low_privilege","summary":"Authenticated users can execute malicious JavaScript in other users' sessions via file uploads, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sysreptor","vendor":"syslifters"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"SysReptor is a fully customizable pentest reporting platform. Prior to 2025.102, there is a Stored Cross-Site Scripting (XSS) vulnerability allows authenticated users to execute malicious JavaScript in the context of other logged-in users by uploading malicious JavaScript files in the web UI. This vulnerability is fixed in 2025.102.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"SysReptor Vulnerable to an Authenticated Stored Cross-Site Scripting (XSS)","id":"CVE-2025-66561","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"TUUI vulnerable to Remote Code Execution (RCE) via XSS in Markdown ECharts Rendering","id":"CVE-2025-66562"},"packages":[],"prev":{"headline":"Quarkus REST has potential worker thread starvation when HTTP connection is closed while waiting to write","id":"CVE-2025-66560"},"products":["sysreptor"],"published":"2025-12-04","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2024-36076","kev_date_added":null,"published":"2024-05-19"},{"cvss_score":8.1,"headline":"SysReptor Susceptible to Privilege Escalation by Authenticated Users","id":"CVE-2025-59945","kev_date_added":null,"published":"2025-09-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-05","vendors":["Syslifters"]},"summary":"Authenticated users can execute malicious JavaScript in other users' sessions via file uploads, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2025-66561/"}