# CVE-2025-66561: SysReptor Vulnerable to an Authenticated Stored Cross-Site Scripting (XSS)

> Authenticated users can execute malicious JavaScript in other users' sessions via file uploads, potentially leading to account takeover.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-64vw-v5c4-mgvm

## What is CVE-2025-66561?

CVE-2025-66561 is a high-severity cross-site scripting vulnerability in Syslifters sysreptor, published on 4 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

SysReptor is a fully customizable pentest reporting platform. Prior to 2025.102, there is a Stored Cross-Site Scripting (XSS) vulnerability allows authenticated users to execute malicious JavaScript in the context of other logged-in users by uploading malicious JavaScript files in the web UI. This vulnerability is fixed in 2025.102.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66561?

It affects 1 product.


Products: Syslifters Sysreptor.

## How do I fix CVE-2025-66561?

No fix has been published for CVE-2025-66561 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66561 being exploited?

There is no known exploitation of CVE-2025-66561 in the wild and no public exploit code.

## Other vulnerabilities in Syslifters sysreptor

- [CVE-2024-36076](https://insights.sbomify.com/CVE-2024-36076/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2025-59945](https://insights.sbomify.com/CVE-2025-59945/): SysReptor Susceptible to Privilege Escalation by Authenticated Users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66561 and fix it if it is affected.

What it is: CVE-2025-66561 is a high-severity cross-site scripting vulnerability in Syslifters sysreptor, published on 4 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-66561 in the wild and no public exploit code.

Affected product: Syslifters sysreptor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66561/ (Markdown: https://insights.sbomify.com/CVE-2025-66561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66561
- OSV: https://osv.dev/vulnerability/CVE-2025-66561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66561/
Summaries are generated and may contain mistakes; the official description above is the record.
