{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66562 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-66562 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-66562 is a high-severity code injection vulnerability in AI-QL tuui, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-66562 and fix it if it is affected.\n\nWhat it is: CVE-2025-66562 is a high-severity code injection vulnerability in AI-QL tuui, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-66562 in the wild and no public exploit code.\n\nAffected product: AI-QL tuui. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66562/ (Markdown: https://insights.sbomify.com/CVE-2025-66562/index.md)","id":"CVE-2025-66562","markdown":"https://insights.sbomify.com/CVE-2025-66562/index.md","name":"CVE-2025-66562","record":{"aliases":["GHSA-qjhq-rgmr-6c3g"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Desktop MCP client","requires_auth":"none","summary":"Attackers can execute arbitrary system commands on victims' machines by exploiting an XSS flaw in Markdown rendering combined with an exposed IPC interface.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"tuui","vendor":"aiql"}],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"TUUI is a desktop MCP client designed as a tool unitary utility integration. Prior to 1.3.4, a critical Remote Code Execution (RCE) vulnerability exists in Tuui due to an unsafe Cross-Site Scripting (XSS) flaw in the Markdown rendering component. Tuui allows the execution of arbitrary JavaScript within ECharts code blocks. Combined with an exposed IPC interface that allows spawning processes, an attacker can execute arbitrary system commands on the victim's machine simply by having them view a malicious Markdown message. This vulnerability is fixed in 1.3.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"TUUI vulnerable to Remote Code Execution (RCE) via XSS in Markdown ECharts Rendering","id":"CVE-2025-66562","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Monkeytype vulnerable to stored XSS in approve quotes page","id":"CVE-2025-66563"},"packages":[],"prev":{"headline":"SysReptor Vulnerable to an Authenticated Stored Cross-Site Scripting (XSS)","id":"CVE-2025-66561"},"products":["tuui"],"published":"2025-12-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-05","vendors":["AI-QL"]},"summary":"Attackers can execute arbitrary system commands on victims' machines by exploiting an XSS flaw in Markdown rendering combined with an exposed IPC interface.","url":"https://insights.sbomify.com/CVE-2025-66562/"}