# CVE-2025-66564: Sigstore Timestamp Authority allocates excessive memory during request parsing

> Attackers can cause excessive memory allocation and denial of service by sending malicious requests with long OIDs or malformed headers to Sigstore Timestamp Authority.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** CLEANSTART-2026-TJ10737, CLEANSTART-2026-UX86931, CLEANSTART-2026-WN78905, DEBIAN-CVE-2025-66564, GHSA-4qg8-fj49-pxjh, GO-2025-4192, MINI-2j4f-9f29-79rh, MINI-2r4h-7q3f-8p45, MINI-34hc-xrgr-84mv, MINI-39qh-phj9-x3m8, MINI-4f62-98v5-mhqc, MINI-4qj6-wx2c-4rf9, MINI-4rfq-ccw4-6q72, MINI-67x4-7cf8-43f3, MINI-7jp8-52c4-v936, MINI-8c59-4vqj-2mgj, MINI-8q32-mrq5-5347, MINI-9fx3-932v-x43j, MINI-9xxw-c5p9-fx9r, MINI-f7jg-hqrm-fwhq, MINI-g3h9-w8mf-rpp4, MINI-hg5x-6mv4-wfff, MINI-j2g9-9p8x-6998, MINI-j8cv-8jrr-6ccv, MINI-pxvm-fr3r-7f58, MINI-q82f-fm6h-hj6w, MINI-r72m-5jj7-3jrj, MINI-rr4f-5rw8-mjfr, MINI-vhw9-4pjr-r6rr, MINI-w6q5-8vwg-q3j4, MINI-wfm7-5g2j-xj7f, UBUNTU-CVE-2025-66564

## What is CVE-2025-66564?

CVE-2025-66564 is a high-severity denial of service vulnerability in sigstore timestamp-authority, published on 4 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sigstore Timestamp Authority is a service for issuing RFC 3161 timestamps. Prior to 2.0.3, Function api.ParseJSONRequest currently splits (via a call to strings.Split) an optionally-provided OID (which is untrusted data) on periods. Similarly, function api.getContentType splits the Content-Type header (which is also untrusted data) on an application string. As a result, in the face of a malicious request with either an excessively long OID in the payload containing many period characters or a malformed Content-Type header, a call to api.ParseJSONRequest or api.getContentType incurs allocations of O(n) bytes (where n stands for the length of the function's argument). This vulnerability is fixed in 2.0.3.

Weakness: CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2025-66564?

4 open source packages ship an affected version, including github.com/sigstore/timestamp-authority and github.com/sigstore/timestamp-authority/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/timestamp-authority` | Go | All versions | None |
| `github.com/sigstore/timestamp-authority` | Go | All versions | 2.0.3 |
| `github.com/sigstore/timestamp-authority` | Go | All versions | 2.0.3 |
| `github.com/sigstore/timestamp-authority/v2` | Go | All versions | 2.0.3 |

Products: Linuxfoundation Sigstore Timestamp Authority.

## How do I fix CVE-2025-66564?

Upgrade github.com/sigstore/timestamp-authority to 2.0.3 or later.

## Is CVE-2025-66564 being exploited?

There is no known exploitation of CVE-2025-66564 in the wild and no public exploit code.

## Other vulnerabilities in sigstore timestamp-authority

- [CVE-2026-49835](https://insights.sbomify.com/CVE-2026-49835/): Sigstore Timestamp Authority: OOM due to unbounded metric label cardinality (medium 5.9)
- [CVE-2026-39984](https://insights.sbomify.com/CVE-2026-39984/): Sigstore Timestamp Authority has Improper Certificate Validation in verifier (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66564 and fix it if it is affected.

What it is: CVE-2025-66564 is a high-severity denial of service vulnerability in sigstore timestamp-authority, published on 4 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66564 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sigstore/timestamp-authority (Go): affected all versions; no fix listed
- github.com/sigstore/timestamp-authority (Go): affected all versions; fixed in 2.0.3
- github.com/sigstore/timestamp-authority (Go): affected all versions; fixed in 2.0.3
- github.com/sigstore/timestamp-authority/v2 (Go): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66564/ (Markdown: https://insights.sbomify.com/CVE-2025-66564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66564
- OSV: https://osv.dev/vulnerability/CVE-2025-66564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66564/
Summaries are generated and may contain mistakes; the official description above is the record.
