# CVE-2025-66565: Fiber Utils UUIDv4 and UUID Silent Fallback to Predictable Values

> Fiber Utils silently returns predictable UUIDs when cryptographic random generation fails, compromising security-critical operations in Fiber applications.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-m98w-cqp3-qcqr, GO-2025-4208

## What is CVE-2025-66565?

CVE-2025-66565 is a critical vulnerability in gofiber utils, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber Utils is a collection of common functions created for Fiber. In versions 2.0.0-rc.3 and below, when the system's cryptographic random number generator (crypto/rand) fails, both functions silently fall back to returning predictable UUID values, including the zero UUID "00000000-0000-0000-0000-000000000000". The vulnerability occurs through two related but distinct failure paths, both ultimately caused by crypto/rand.Read() failures, compromising the security of all Fiber applications using these functions for security-critical operations. This issue is fixed in version 2.0.0-rc.4.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)), CWE-331 (Insufficient Entropy), CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2025-66565?

6 open source packages ship an affected version, including github.com/gofiber/utils and github.com/gofiber/utils/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/utils` | Go | All versions | 1.2.0 |
| `github.com/gofiber/utils` | Go | All versions | 1.2.0 |
| `github.com/gofiber/utils` | Go | All versions | 1.2.0 |
| `github.com/gofiber/utils/v2` | Go | All versions | 2.0.0-rc.4 |
| `github.com/gofiber/utils/v2` | Go | All versions | 2.0.0-rc.4 |
| `github.com/gofiber/utils/v2` | Go | All versions | 2.0.0-rc.4 |

Products: Gofiber Utils.

## How do I fix CVE-2025-66565?

Upgrade github.com/gofiber/utils to 1.2.0 or later.

## Is CVE-2025-66565 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66565 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66565 and fix it if it is affected.

What it is: CVE-2025-66565 is a critical vulnerability in gofiber utils, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66565 exists.

Affected packages and fixed versions:
- github.com/gofiber/utils (Go): affected all versions; fixed in 1.2.0
- github.com/gofiber/utils (Go): affected all versions; fixed in 1.2.0
- github.com/gofiber/utils (Go): affected all versions; fixed in 1.2.0
- github.com/gofiber/utils/v2 (Go): affected all versions; fixed in 2.0.0-rc.4
- github.com/gofiber/utils/v2 (Go): affected all versions; fixed in 2.0.0-rc.4
- github.com/gofiber/utils/v2 (Go): affected all versions; fixed in 2.0.0-rc.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66565/ (Markdown: https://insights.sbomify.com/CVE-2025-66565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66565
- OSV: https://osv.dev/vulnerability/CVE-2025-66565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66565/
Summaries are generated and may contain mistakes; the official description above is the record.
