CVE-2025-66566 yawkat LZ4 Java has a possible information leak in Java safe decompressor
Remote attackers can read sensitive data from previous buffer contents via crafted compressed input in the Java safe decompressor.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66566?
CVE-2025-66566 is a high-severity vulnerability in yawkat lz4-java, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. This vulnerability is fixed in 1.10.1.
Weakness: CWE-201
Which versions are affected by CVE-2025-66566?
8 open source packages ship an affected version, including at.yawk.lz4:lz4-java, net.jpountz.lz4:lz4 and org.lz4:lz4-java.
| Package | Affected | Fixed in |
|---|---|---|
at.yawk.lz4:lz4-java Maven | All versions | 1.10.1 |
at.yawk.lz4:lz4-java Maven | All versions | 1.10.1 |
net.jpountz.lz4:lz4 Maven | All versions to 1.8.1 | None |
net.jpountz.lz4:lz4 Maven | All versions to 1.8.1 | None |
org.lz4:lz4-java Maven | All versions to 1.8.1 | None |
org.lz4:lz4-java Maven | All versions to 1.8.1 | None |
2 more packages
org.lz4:lz4-pure-java Maven | All versions to 1.8.1 | None |
org.lz4:lz4-pure-java Maven | All versions to 1.8.1 | None |
Linux distribution packages (5)
jmc AlmaLinux:9 | All versions | 8.2.0-18.el9_7.2 |
jmc Red Hat:enterprise_linux:9::crb | All versions | 0:8.2.0-18.el9_7.2 |
jmc Red Hat:rhel_eus:9.4::crb | All versions | 0:8.2.0-17.el9_4.2 |
jmc Red Hat:rhel_eus:9.6::crb | All versions | 0:8.2.0-18.el9_6.2 |
jmc Rocky Linux:9 | All versions | 0:8.2.0-18.el9_7.2 |
How do I fix CVE-2025-66566?
Upgrade at.yawk.lz4:lz4-java to 1.10.1 or later.
Is CVE-2025-66566 being exploited?
There is no known exploitation of CVE-2025-66566 in the wild and no public exploit code.
Sources
Also known as ALSA-2026:0752, CLEANSTART-2026-MK18357, CLEANSTART-2026-UB44506, CLEANSTART-2026-YG17751, CLSA-2026-1770768563, DEBIAN-CVE-2025-66566 and 58 more.