# CVE-2025-66566: yawkat LZ4 Java has a possible information leak in Java safe decompressor

> Remote attackers can read sensitive data from previous buffer contents via crafted compressed input in the Java safe decompressor.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** ALSA-2026:0752, CLEANSTART-2026-MK18357, CLEANSTART-2026-UB44506, CLEANSTART-2026-YG17751, CLSA-2026-1770768563, DEBIAN-CVE-2025-66566, ECHO-a02e-e8de-2b03, GHSA-cmp6-m4wj-q63q, MINI-2f7h-3rmg-4wgf, MINI-43rm-p9j2-6p4g, MINI-4fjw-6j78-5g29, MINI-4wcv-qpqv-86m2, MINI-53hq-9m3x-rmr7, MINI-54gr-qf55-g8qm, MINI-5whh-jv2j-7vv4, MINI-6gqw-vxjc-qchh, MINI-6mwx-9x8c-2xgq, MINI-6w6x-mv2c-33vv, MINI-73cg-gc4j-24j5, MINI-75xv-87mp-526g, MINI-76xq-hp58-m2xc, MINI-773p-h3hm-4wrg, MINI-7crp-hjcv-m9cp, MINI-84p5-f3h8-hg24, MINI-8c88-m388-mgxw, MINI-8xq4-prfp-46mg, MINI-934g-wjpw-phcp, MINI-96fh-5763-6gx2, MINI-96vq-952f-9jgx, MINI-9gmp-77hw-f8mx, MINI-9mwv-9x7w-r4p8, MINI-cf7q-9frv-7pwr, MINI-cqqq-c96x-4fc7, MINI-cr6x-96wp-gmcc, MINI-crg6-vcpq-4mmp, MINI-cw6r-9796-gc3v, MINI-f4vg-5gcg-wj9x, MINI-fjwx-hf3f-5h7h, MINI-g2qc-2877-gg33, MINI-h6mv-wxj3-c435, MINI-h6xp-wxf5-q63w, MINI-hjqm-hh8w-hm4c, MINI-hwmw-mvmp-5rv6, MINI-jm4c-wrwf-9jp3, MINI-p23x-6845-rgwg, MINI-p4mq-5jg9-hhwh, MINI-pphw-wm2c-g8q2, MINI-q452-r37h-j9cm, MINI-q9fp-336q-77q6, MINI-qcx9-v9qh-qp2f, MINI-qjpj-mwwr-pp8r, MINI-qv6c-qhrg-8548, MINI-r66h-26mg-jm67, MINI-rqgg-m655-vxg3, MINI-w6cc-6p9c-mqx8, MINI-w9m7-7352-5vj8, MINI-w9p6-45gr-7xfw, MINI-wvq8-jwpr-hhh9, RHSA-2026:0751, RHSA-2026:0752, RHSA-2026:1823, RLSA-2026:0752, ROOT-APP-MAVEN-CVE-2025-66566, UBUNTU-CVE-2025-66566

## What is CVE-2025-66566?

CVE-2025-66566 is a high-severity vulnerability in yawkat lz4-java, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. This vulnerability is fixed in 1.10.1.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-66566?

8 open source packages ship an affected version, including at.yawk.lz4:lz4-java, net.jpountz.lz4:lz4 and org.lz4:lz4-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.10.1 |
| `at.yawk.lz4:lz4-java` | Maven | All versions | 1.10.1 |
| `net.jpountz.lz4:lz4` | Maven | All versions to 1.8.1 | None |
| `net.jpountz.lz4:lz4` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-java` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-pure-java` | Maven | All versions to 1.8.1 | None |
| `org.lz4:lz4-pure-java` | Maven | All versions to 1.8.1 | None |
| `jmc` | AlmaLinux:9 | All versions | 8.2.0-18.el9_7.2 |
| `jmc` | Red Hat:enterprise_linux:9::crb | All versions | 0:8.2.0-18.el9_7.2 |
| `jmc` | Red Hat:rhel_eus:9.4::crb | All versions | 0:8.2.0-17.el9_4.2 |
| `jmc` | Red Hat:rhel_eus:9.6::crb | All versions | 0:8.2.0-18.el9_6.2 |
| `jmc` | Rocky Linux:9 | All versions | 0:8.2.0-18.el9_7.2 |

## How do I fix CVE-2025-66566?

Upgrade at.yawk.lz4:lz4-java to 1.10.1 or later.

## Is CVE-2025-66566 being exploited?

There is no known exploitation of CVE-2025-66566 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66566 and fix it if it is affected.

What it is: CVE-2025-66566 is a high-severity vulnerability in yawkat lz4-java, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66566 in the wild and no public exploit code.

Affected packages and fixed versions:
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.10.1
- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.10.1
- net.jpountz.lz4:lz4 (Maven): affected all versions up to 1.8.1; no fix listed
- net.jpountz.lz4:lz4 (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-java (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-pure-java (Maven): affected all versions up to 1.8.1; no fix listed
- org.lz4:lz4-pure-java (Maven): affected all versions up to 1.8.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66566/ (Markdown: https://insights.sbomify.com/CVE-2025-66566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66566
- OSV: https://osv.dev/vulnerability/CVE-2025-66566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66566/
Summaries are generated and may contain mistakes; the official description above is the record.
