{"answers":{"affected":"2 open source packages ship an affected version, including ruby-saml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66567 in the wild and no public exploit code.","fix":"Upgrade ruby-saml to 1.18.0 or later.","what":"CVE-2025-66567 is a critical authentication bypass vulnerability in SAML-Toolkits ruby-saml, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66567 and fix it if it is affected.\n\nWhat it is: CVE-2025-66567 is a critical authentication bypass vulnerability in SAML-Toolkits ruby-saml, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-66567 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-saml (RubyGems): affected all versions; fixed in 1.18.0\n- ruby-saml (RubyGems): affected all versions; fixed in 1.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66567/ (Markdown: https://insights.sbomify.com/CVE-2025-66567/index.md)","id":"CVE-2025-66567","markdown":"https://insights.sbomify.com/CVE-2025-66567/index.md","name":"CVE-2025-66567","record":{"aliases":["GHSA-9v8j-x534-2fx3","UBUNTU-CVE-2025-66567"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"none","summary":"Attackers can bypass SAML authentication via signature wrapping due to XML parser differences in ruby-saml.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ruby-saml","vendor":"onelogin"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)","id":"CVE-2025-66567","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation","id":"CVE-2025-66568"},"packages":[{"ecosystem":"RubyGems","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-9v8j-x534-2fx3"},{"ecosystem":"RubyGems","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-9v8j-x534-2fx3"}],"prev":{"headline":"yawkat LZ4 Java has a possible information leak in Java safe decompressor","id":"CVE-2025-66566"},"products":["ruby-saml"],"published":"2025-12-09","related":[{"cvss_score":9.8,"headline":"ruby-saml vulnerable to XPath injection","id":"CVE-2015-20108","kev_date_added":null,"published":"2023-05-27"},{"cvss_score":9.3,"headline":"ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation","id":"CVE-2025-66568","kev_date_added":null,"published":"2025-12-09"},{"cvss_score":7.7,"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11428","kev_date_added":null,"published":"2019-04-17"},{"cvss_score":7.5,"headline":"Ruby-saml allows attackers to perform XML signature wrapping attacks","id":"CVE-2016-5697","kev_date_added":null,"published":"2017-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["SAML-Toolkits"]},"summary":"Attackers can bypass SAML authentication via signature wrapping due to XML parser differences in ruby-saml.","url":"https://insights.sbomify.com/CVE-2025-66567/"}