# CVE-2025-66568: ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation

> Attackers can bypass SAML signature validation via libxml2 canonicalization errors, allowing unauthorized access to applications using ruby-saml.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-x4h9-gwv3-r4m4, UBUNTU-CVE-2025-66568

## What is CVE-2025-66568?

CVE-2025-66568 is a critical authentication bypass vulnerability in SAML-Toolkits ruby-saml, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ruby-saml library implements the client side of an SAML authorization. Versions up to and including 1.12.4, are vulnerable to authentication bypass through the libxml2 canonicalization process used by Nokogiri for document transformation, which allows an attacker to execute a Signature Wrapping attack. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. ruby-saml then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 1.18.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-66568?

2 open source packages ship an affected version, including ruby-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-saml` | RubyGems | All versions | 1.18.0 |
| `ruby-saml` | RubyGems | All versions | 1.18.0 |

Products: Onelogin Ruby-Saml.

## How do I fix CVE-2025-66568?

Upgrade ruby-saml to 1.18.0 or later.

## Is CVE-2025-66568 being exploited?

There is no known exploitation of CVE-2025-66568 in the wild and no public exploit code.

## Other vulnerabilities in SAML-Toolkits ruby-saml

- [CVE-2015-20108](https://insights.sbomify.com/CVE-2015-20108/): ruby-saml vulnerable to XPath injection (critical 9.8)
- [CVE-2025-66567](https://insights.sbomify.com/CVE-2025-66567/): ruby-saml has a SAML authentication bypass due to namespace handling (parser differential) (critical 9.3)
- [CVE-2017-11428](https://insights.sbomify.com/CVE-2017-11428/): Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal (high 7.7)
- [CVE-2016-5697](https://insights.sbomify.com/CVE-2016-5697/): Ruby-saml allows attackers to perform XML signature wrapping attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66568 and fix it if it is affected.

What it is: CVE-2025-66568 is a critical authentication bypass vulnerability in SAML-Toolkits ruby-saml, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66568 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-saml (RubyGems): affected all versions; fixed in 1.18.0
- ruby-saml (RubyGems): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66568/ (Markdown: https://insights.sbomify.com/CVE-2025-66568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66568
- OSV: https://osv.dev/vulnerability/CVE-2025-66568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66568/
Summaries are generated and may contain mistakes; the official description above is the record.
