# CVE-2025-66570: cpp-httplib Untrusted HTTP Header Handling: Internal Header Shadowing (REMOTE*/LOCAL*)

> Attackers can spoof IP addresses and bypass authorization by injecting internal HTTP headers that shadow server-generated metadata in cpp-httplib.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** DEBIAN-CVE-2025-66570, ECHO-ca5e-a5a0-245b, GHSA-xm2j-vfr9-mg9m, UBUNTU-CVE-2025-66570, USN-7962-1

## What is CVE-2025-66570?

CVE-2025-66570 is a critical vulnerability in yhirose cpp-httplib, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. Prior to 0.27.0, a vulnerability allows attacker-controlled HTTP headers to influence server-visible metadata, logging, and authorization decisions. An attacker can inject headers named REMOTE_ADDR, REMOTE_PORT, LOCAL_ADDR, LOCAL_PORT that are parsed into the request header multimap via read_headers() in httplib.h (headers.emplace), then the server later appends its own internal metadata using the same header names in Server::process_request without erasing duplicates. Because Request::get_header_value returns the first entry for a header key (id == 0) and the client-supplied headers are parsed before server-inserted headers, downstream code that uses these header names may inadvertently use attacker-controlled values. Affected files/locations: cpp-httplib/httplib.h (read_headers, Server::process_request, Request::get_header_value, get_header_value_u64) and cpp-httplib/docker/main.cc (get_client_ip, nginx_access_logger, nginx_error_logger). Attack surface: attacker-controlled HTTP headers in incoming requests flow into the Request.headers multimap and into logging code that reads forwarded headers, enabling IP spoofing, log poisoning, and authorization bypass via header shadowing. This vulnerability is fixed in 0.27.0.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision), CWE-345 (Insufficient Verification of Data Authenticity), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-66570?

It affects 1 product.


Products: Yhirose Cpp-Httplib.

## How do I fix CVE-2025-66570?

Upgrade to a fixed version.

## Is CVE-2025-66570 being exploited?

There is no known exploitation of CVE-2025-66570 in the wild and no public exploit code.

## Other vulnerabilities in yhirose cpp-httplib

- [CVE-2026-45372](https://insights.sbomify.com/CVE-2026-45372/): cpp-httplib: HTTP header value percent-decoding in server-side `parse_header` enables CRLF injection (critical 9.9)
- [CVE-2026-46527](https://insights.sbomify.com/CVE-2026-46527/): Null dereference in cpp-httplib (high 8.7)
- [CVE-2026-32627](https://insights.sbomify.com/CVE-2026-32627/): cpp-httplib has a Silent TLS Certificate Verification Bypass on HTTPS Redirect via Proxy (high 8.7)
- [CVE-2026-22776](https://insights.sbomify.com/CVE-2026-22776/): cpp-httplib vulnerable to a denial of service (DOS) using a zip bomb (high 8.7)
- [CVE-2026-21428](https://insights.sbomify.com/CVE-2026-21428/): cpp-httplib has CRLF injection in http headers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66570 and fix it if it is affected.

What it is: CVE-2025-66570 is a critical vulnerability in yhirose cpp-httplib, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66570 in the wild and no public exploit code.

Affected product: yhirose cpp-httplib. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66570/ (Markdown: https://insights.sbomify.com/CVE-2025-66570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66570
- OSV: https://osv.dev/vulnerability/CVE-2025-66570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66570/
Summaries are generated and may contain mistakes; the official description above is the record.
