{"answers":{"affected":"2 open source packages ship an affected version, including robrichards/xmlseclibs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66578 in the wild and no public exploit code.","fix":"Upgrade robrichards/xmlseclibs to 3.1.4 or later.","what":"CVE-2025-66578 is a medium-severity vulnerability in robrichards xmlseclibs, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66578 and fix it if it is affected.\n\nWhat it is: CVE-2025-66578 is a medium-severity vulnerability in robrichards xmlseclibs, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-66578 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- robrichards/xmlseclibs (Packagist): affected all versions; fixed in 3.1.4\n- robrichards/xmlseclibs (Packagist): affected all versions; fixed in 3.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66578/ (Markdown: https://insights.sbomify.com/CVE-2025-66578/index.md)","id":"CVE-2025-66578","markdown":"https://insights.sbomify.com/CVE-2025-66578/index.md","name":"CVE-2025-66578","record":{"aliases":["GHSA-c4cc-x928-vjw9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP XML security library","requires_auth":"high_privilege","summary":"Attackers can bypass XML signature validation by exploiting a canonicalization error in xmlseclibs, allowing unsigned or tampered content to be accepted as valid.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"xmlseclibs","vendor":"xmlseclibs_project"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"xmlseclibs is a library written in PHP for working with XML Encryption and Signatures. Versions 3.1.3 contain an authentication bypass vulnerability due to a flaw in the libxml2 canonicalization process during document transformation. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. xmlseclibs then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 3.1.4. Workarounds include treating canonicalization failures (exceptions or nil/empty outputs) as fatal and aborting validation, and/or adding explicit checks to reject when canonicalize returns nil/empty or raises errors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"robrichards/xmlseclibs has an Libxml2 Canonicalization error which can bypass Digest/Signature validation","id":"CVE-2025-66578","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Dive has Cross-Site Scripting vulnerability that can escalate to Remote Code Execution","id":"CVE-2025-66580"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["0"],"last_affected":[],"package":"robrichards/xmlseclibs","purl":null,"source":"GHSA-c4cc-x928-vjw9"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["0"],"last_affected":[],"package":"robrichards/xmlseclibs","purl":"pkg:composer/robrichards/xmlseclibs","source":"GHSA-c4cc-x928-vjw9"}],"prev":{"headline":"cpp-httplib Untrusted HTTP Header Handling: X-Forwarded-For/X-Real-IP Trust","id":"CVE-2025-66577"},"products":["xmlseclibs"],"published":"2025-12-09","related":[{"cvss_score":8.2,"headline":"xmlseclibs is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption","id":"CVE-2026-32313","kev_date_added":null,"published":"2026-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["robrichards"]},"summary":"Attackers can bypass XML signature validation by exploiting a canonicalization error in xmlseclibs, allowing unsigned or tampered content to be accepted as valid.","url":"https://insights.sbomify.com/CVE-2025-66578/"}