# CVE-2025-66578: robrichards/xmlseclibs has an Libxml2 Canonicalization error which can bypass Digest/Signature validation

> Attackers can bypass XML signature validation by exploiting a canonicalization error in xmlseclibs, allowing unsigned or tampered content to be accepted as valid.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-c4cc-x928-vjw9

## What is CVE-2025-66578?

CVE-2025-66578 is a medium-severity vulnerability in robrichards xmlseclibs, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

xmlseclibs is a library written in PHP for working with XML Encryption and Signatures. Versions 3.1.3 contain an authentication bypass vulnerability due to a flaw in the libxml2 canonicalization process during document transformation. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. xmlseclibs then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 3.1.4. Workarounds include treating canonicalization failures (exceptions or nil/empty outputs) as fatal and aborting validation, and/or adding explicit checks to reject when canonicalize returns nil/empty or raises errors.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-66578?

2 open source packages ship an affected version, including robrichards/xmlseclibs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `robrichards/xmlseclibs` | Packagist | All versions | 3.1.4 |
| `robrichards/xmlseclibs` | Packagist | All versions | 3.1.4 |

Products: Xmlseclibs Project Xmlseclibs.

## How do I fix CVE-2025-66578?

Upgrade robrichards/xmlseclibs to 3.1.4 or later.

## Is CVE-2025-66578 being exploited?

There is no known exploitation of CVE-2025-66578 in the wild and no public exploit code.

## Other vulnerabilities in robrichards xmlseclibs

- [CVE-2026-32313](https://insights.sbomify.com/CVE-2026-32313/): xmlseclibs is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66578 and fix it if it is affected.

What it is: CVE-2025-66578 is a medium-severity vulnerability in robrichards xmlseclibs, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66578 in the wild and no public exploit code.

Affected packages and fixed versions:
- robrichards/xmlseclibs (Packagist): affected all versions; fixed in 3.1.4
- robrichards/xmlseclibs (Packagist): affected all versions; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66578/ (Markdown: https://insights.sbomify.com/CVE-2025-66578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66578
- OSV: https://osv.dev/vulnerability/CVE-2025-66578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66578/
Summaries are generated and may contain mistakes; the official description above is the record.
