# CVE-2025-66581: Frappe LMS is Missing Server-Side Authorization in Business Logic

> Authenticated low-privileged users can perform instructor or admin actions via API due to missing server-side authorization checks.

- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-2ch7-c74m-432m

## What is CVE-2025-66581?

CVE-2025-66581 is a low-severity missing authorization vulnerability in frappe lms, published on 5 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to 2.41.0, a flaw in the server-side authorization logic allowed authenticated users to perform actions beyond their assigned roles across multiple features. Because the affected endpoints relied on client-side or UI-level checks instead of enforcing permissions on the server, users with low-privileged roles (such as students) could perform operations intended only for instructors or administrators via directly using the API's. This vulnerability is fixed in 2.41.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-66581?

It affects 1 product.


Products: Frappe Learning.

## How do I fix CVE-2025-66581?

No fix has been published for CVE-2025-66581 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66581 being exploited?

There is no known exploitation of CVE-2025-66581 in the wild and no public exploit code.

## Other vulnerabilities in frappe lms

- [CVE-2023-5555](https://insights.sbomify.com/CVE-2023-5555/): Cross-site Scripting (XSS) - Generic in frappe/lms (high 7.1)
- [CVE-2026-34606](https://insights.sbomify.com/CVE-2026-34606/): Stored XSS in Frappe LMS (medium 6.9)
- [CVE-2026-26977](https://insights.sbomify.com/CVE-2026-26977/): Frappe Learning Management System exposes details of unpublished courses to unauthorized users (medium 6.9)
- [CVE-2025-11280](https://insights.sbomify.com/CVE-2025-11280/): Frappe LMS Assignment Picture files direct request (medium 6.3)
- [CVE-2023-42807](https://insights.sbomify.com/CVE-2023-42807/): Frappe LMS SQL Injection Issue on People Page (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66581 and fix it if it is affected.

What it is: CVE-2025-66581 is a low-severity missing authorization vulnerability in frappe lms, published on 5 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66581 in the wild and no public exploit code.

Affected product: frappe lms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66581/ (Markdown: https://insights.sbomify.com/CVE-2025-66581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66581
- OSV: https://osv.dev/vulnerability/CVE-2025-66581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66581/
Summaries are generated and may contain mistakes; the official description above is the record.
