CVE-2025-66614 Apache Tomcat: Client certificate verification bypass due to virtual host mapping
Attackers can bypass client certificate authentication in Apache Tomcat by mismatching SNI and Host headers when multiple virtual hosts are configured.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66614?
CVE-2025-66614 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 17 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Input Validation vulnerability.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field.
The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web application.
Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fix the issue.
Which versions are affected by CVE-2025-66614?
25 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.50 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.50 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.15 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.15 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
19 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.113 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.113 |
tomcat Bitnami | From 8.5.0 | 9.0.113, 10.1.50, 11.0.15 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.50 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.50 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.15 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.15 |
org.apache.tomcat:tomcat Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 9.0.0-M1 | 9.0.113 |
org.apache.tomcat:tomcat Maven | From 9.0.0-M1 | 9.0.113 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.50 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.50 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.15 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.15 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M1 | 9.0.113 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M1 | 9.0.113 |
Products include Apache Tomcat.
How do I fix CVE-2025-66614?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.50, 11.0.15 or 9.0.113.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-66614 being exploited?
There is no known exploitation of CVE-2025-66614 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-66614, CLEANSTART-2026-BB54045, CLSA-2026-1773941493, CLSA-2026-1774261838, CLSA-2026-1774426919, CLSA-2026-1774431936 and 13 more.