{"answers":{"affected":"8 open source packages ship an affected version, including wasmi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66627 in the wild and no public exploit code.","fix":"Upgrade wasmi to a fixed version for your release line: 0.41.2, 0.47.1, 0.51.3 or 1.0.1.","what":"CVE-2025-66627 is a high-severity use after free vulnerability in wasmi-labs wasmi, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66627 and fix it if it is affected.\n\nWhat it is: CVE-2025-66627 is a high-severity use after free vulnerability in wasmi-labs wasmi, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-66627 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wasmi (crates.io): affected from 0.41.0; fixed in 0.41.2\n- wasmi (crates.io): affected from 0.41.0; fixed in 0.41.2\n- wasmi (crates.io): affected from 0.42.0; fixed in 0.47.1\n- wasmi (crates.io): affected from 0.42.0; fixed in 0.47.1\n- wasmi (crates.io): affected from 0.50.0; fixed in 0.51.3\n- wasmi (crates.io): affected from 0.50.0; fixed in 0.51.3\n- wasmi (crates.io): affected from 1.0.0; fixed in 1.0.1\n- wasmi (crates.io): affected from 1.0.0; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66627/ (Markdown: https://insights.sbomify.com/CVE-2025-66627/index.md)","id":"CVE-2025-66627","markdown":"https://insights.sbomify.com/CVE-2025-66627/index.md","name":"CVE-2025-66627","record":{"aliases":["GHSA-g4v2-cjqp-rfmq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"WebAssembly interpreter","requires_auth":"none","summary":"A use-after-free flaw in Wasmi allows attackers to execute code or disclose information via malicious WebAssembly modules.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wasmi","vendor":"wasmi-labs"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Wasmi is a WebAssembly interpreter focused on constrained and embedded systems. In versions 0.41.0, 0.41.1, 0.42.0 through 0.47.1, 0.50.0 through 0.51.2 and 1.0.0, Wasmi's linear memory implementation leads to a Use After Free vulnerability, triggered by a WebAssembly module under certain memory growth conditions. This issue potentially leads to memory corruption, information disclosure, or code execution. This issue is fixed in versions 0.41.2, 0.47.1, 0.51.3 and 1.0.1. To workaround this issue, consider limiting the maximum linear memory sizes where feasible.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wasmi's Linear Memory has a Critical Use After Free Vulnerability","id":"CVE-2025-66627","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"use_after_free","year":"2025"},"n_packages":8,"n_references":1,"next":{"headline":"ImageMagick is vulnerable to an Integer Overflow in TIM decoder leading to out of bounds read (32-bit only)","id":"CVE-2025-66628"},"packages":[{"ecosystem":"crates.io","fixed":["0.41.2"],"introduced":["0.41.0"],"last_affected":[],"package":"wasmi","purl":null,"source":"GHSA-g4v2-cjqp-rfmq"},{"ecosystem":"crates.io","fixed":["0.41.2"],"introduced":["0.41.0"],"last_affected":[],"package":"wasmi","purl":"pkg:cargo/wasmi","source":"GHSA-g4v2-cjqp-rfmq"},{"ecosystem":"crates.io","fixed":["0.47.1"],"introduced":["0.42.0"],"last_affected":[],"package":"wasmi","purl":null,"source":"GHSA-g4v2-cjqp-rfmq"},{"ecosystem":"crates.io","fixed":["0.47.1"],"introduced":["0.42.0"],"last_affected":[],"package":"wasmi","purl":"pkg:cargo/wasmi","source":"GHSA-g4v2-cjqp-rfmq"},{"ecosystem":"crates.io","fixed":["0.51.3"],"introduced":["0.50.0"],"last_affected":[],"package":"wasmi","purl":null,"source":"GHSA-g4v2-cjqp-rfmq"},{"ecosystem":"crates.io","fixed":["0.51.3"],"introduced":["0.50.0"],"last_affected":[],"package":"wasmi","purl":"pkg:cargo/wasmi","source":"GHSA-g4v2-cjqp-rfmq"},{"ecosystem":"crates.io","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"wasmi","purl":null,"source":"GHSA-g4v2-cjqp-rfmq"},{"ecosystem":"crates.io","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"wasmi","purl":"pkg:cargo/wasmi","source":"GHSA-g4v2-cjqp-rfmq"}],"prev":{"headline":"argoproj/argo-workflows is vulnerable to RCE via ZipSlip and symbolic links","id":"CVE-2025-66626"},"products":["wasmi"],"published":"2025-12-09","related":[{"cvss_score":7.3,"headline":"Wasmi Out-of-bounds Write for host to Wasm calls with more than 128 Parameters","id":"CVE-2024-28123","kev_date_added":null,"published":"2024-03-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["wasmi-labs"]},"summary":"A use-after-free flaw in Wasmi allows attackers to execute code or disclose information via malicious WebAssembly modules.","url":"https://insights.sbomify.com/CVE-2025-66627/"}