# CVE-2025-66627: Wasmi's Linear Memory has a Critical Use After Free Vulnerability

> A use-after-free flaw in Wasmi allows attackers to execute code or disclose information via malicious WebAssembly modules.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-g4v2-cjqp-rfmq

## What is CVE-2025-66627?

CVE-2025-66627 is a high-severity use after free vulnerability in wasmi-labs wasmi, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Wasmi is a WebAssembly interpreter focused on constrained and embedded systems. In versions 0.41.0, 0.41.1, 0.42.0 through 0.47.1, 0.50.0 through 0.51.2 and 1.0.0, Wasmi's linear memory implementation leads to a Use After Free vulnerability, triggered by a WebAssembly module under certain memory growth conditions. This issue potentially leads to memory corruption, information disclosure, or code execution. This issue is fixed in versions 0.41.2, 0.47.1, 0.51.3 and 1.0.1. To workaround this issue, consider limiting the maximum linear memory sizes where feasible.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2025-66627?

8 open source packages ship an affected version, including wasmi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmi` | crates.io | From 0.41.0 | 0.41.2 |
| `wasmi` | crates.io | From 0.41.0 | 0.41.2 |
| `wasmi` | crates.io | From 0.42.0 | 0.47.1 |
| `wasmi` | crates.io | From 0.42.0 | 0.47.1 |
| `wasmi` | crates.io | From 0.50.0 | 0.51.3 |
| `wasmi` | crates.io | From 0.50.0 | 0.51.3 |
| `wasmi` | crates.io | From 1.0.0 | 1.0.1 |
| `wasmi` | crates.io | From 1.0.0 | 1.0.1 |

Products: Wasmi-Labs Wasmi.

## How do I fix CVE-2025-66627?

Upgrade wasmi to a fixed version for your release line: 0.41.2, 0.47.1, 0.51.3 or 1.0.1.

## Is CVE-2025-66627 being exploited?

There is no known exploitation of CVE-2025-66627 in the wild and no public exploit code.

## Other vulnerabilities in wasmi-labs wasmi

- [CVE-2024-28123](https://insights.sbomify.com/CVE-2024-28123/): Wasmi Out-of-bounds Write for host to Wasm calls with more than 128 Parameters (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66627 and fix it if it is affected.

What it is: CVE-2025-66627 is a high-severity use after free vulnerability in wasmi-labs wasmi, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66627 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmi (crates.io): affected from 0.41.0; fixed in 0.41.2
- wasmi (crates.io): affected from 0.41.0; fixed in 0.41.2
- wasmi (crates.io): affected from 0.42.0; fixed in 0.47.1
- wasmi (crates.io): affected from 0.42.0; fixed in 0.47.1
- wasmi (crates.io): affected from 0.50.0; fixed in 0.51.3
- wasmi (crates.io): affected from 0.50.0; fixed in 0.51.3
- wasmi (crates.io): affected from 1.0.0; fixed in 1.0.1
- wasmi (crates.io): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66627/ (Markdown: https://insights.sbomify.com/CVE-2025-66627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66627
- OSV: https://osv.dev/vulnerability/CVE-2025-66627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66627/
Summaries are generated and may contain mistakes; the official description above is the record.
