CVE-2025-66628 ImageMagick is vulnerable to an Integer Overflow in TIM decoder leading to out of bounds read (32-bit only)
An integer overflow in the TIM decoder allows out-of-bounds reads on 32-bit systems, potentially causing crashes or data exposure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66628?
CVE-2025-66628 is a high-severity vulnerability in Imagemagick Imagemagick, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ImageMagick is a software suite to create, edit, compose, or convert bitmap images. In versions 7.1.2-9 and prior, the TIM (PSX TIM) image parser contains a critical integer overflow vulnerability in its ReadTIMImage function (coders/tim.c). The code reads width and height (16-bit values) from the file header and calculates image_size = 2 * width * height without checking for overflow. On 32-bit systems (or where size_t is 32-bit), this calculation can overflow if width and height are large (e.g., 65535), wrapping around to a small value. This results in a small heap allocation via AcquireQuantumMemory and later operations relying on the dimensions can trigger an out of bounds read. This issue is fixed in version 7.1.2-10.
Weakness: CWE-125
Which versions are affected by CVE-2025-66628?
12 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-x86. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
Magick.NET-Q16-AnyCPU NuGet | All versions | 14.10.0 |
Magick.NET-Q16-AnyCPU NuGet | All versions | 14.10.0 |
Magick.NET-Q16-HDRI-AnyCPU NuGet | All versions | 14.10.0 |
Magick.NET-Q16-HDRI-AnyCPU NuGet | All versions | 14.10.0 |
Magick.NET-Q16-HDRI-x86 NuGet | All versions | 14.10.0 |
Magick.NET-Q16-HDRI-x86 NuGet | All versions | 14.10.0 |
6 more packages
Magick.NET-Q16-x86 NuGet | All versions | 14.10.0 |
Magick.NET-Q16-x86 NuGet | All versions | 14.10.0 |
Magick.NET-Q8-AnyCPU NuGet | All versions | 14.10.0 |
Magick.NET-Q8-AnyCPU NuGet | All versions | 14.10.0 |
Magick.NET-Q8-x86 NuGet | All versions | 14.10.0 |
Magick.NET-Q8-x86 NuGet | All versions | 14.10.0 |
Linux distribution packages (3)
ImageMagick SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 6.8.8.1-71.218.1 |
ImageMagick SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 6.8.8.1-71.218.1 |
ImageMagick openSUSE:Tumbleweed | All versions | 7.1.2.10-2.1 |
Products include Imagemagick Imagemagick.
How do I fix CVE-2025-66628?
Upgrade Magick.NET-Q16-AnyCPU to 14.10.0 or later.
Is CVE-2025-66628 being exploited?
There is no known exploitation of CVE-2025-66628 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Imagemagick Imagemagick
Sources
Also known as DEBIAN-CVE-2025-66628, GHSA-6hjr-v6g4-3fm8, JLSEC-2026-929, MINI-g26f-f8cc-wwc2, SUSE-SU-2025:4429-1, UBUNTU-CVE-2025-66628 and 1 more.