# CVE-2025-66628: ImageMagick is vulnerable to an Integer Overflow in TIM decoder leading to out of bounds read (32-bit only)

> An integer overflow in the TIM decoder allows out-of-bounds reads on 32-bit systems, potentially causing crashes or data exposure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** DEBIAN-CVE-2025-66628, GHSA-6hjr-v6g4-3fm8, JLSEC-2026-929, MINI-g26f-f8cc-wwc2, SUSE-SU-2025:4429-1, UBUNTU-CVE-2025-66628, openSUSE-SU-2025:15829-1

## What is CVE-2025-66628?

CVE-2025-66628 is a high-severity vulnerability in Imagemagick Imagemagick, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ImageMagick is a software suite to create, edit, compose, or convert bitmap images. In versions 7.1.2-9 and prior, the TIM (PSX TIM) image parser contains a critical integer overflow vulnerability in its ReadTIMImage function (coders/tim.c). The code reads width and height (16-bit values) from the file header and calculates image_size = 2 * width * height without checking for overflow. On 32-bit systems (or where size_t is 32-bit), this calculation can overflow if width and height are large (e.g., 65535), wrapping around to a small value. This results in a small heap allocation via AcquireQuantumMemory and later operations relying on the dimensions can trigger an out of bounds read. This issue is fixed in version 7.1.2-10.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-66628?

12 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-x86. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.0 |
| `ImageMagick` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 6.8.8.1-71.218.1 |
| `ImageMagick` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 6.8.8.1-71.218.1 |
| `ImageMagick` | openSUSE:Tumbleweed | All versions | 7.1.2.10-2.1 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2025-66628?

Upgrade Magick.NET-Q16-AnyCPU to 14.10.0 or later.

## Is CVE-2025-66628 being exploited?

There is no known exploitation of CVE-2025-66628 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Sumitshah00/CVE-2025-66628 (github_poc): https://github.com/Sumitshah00/CVE-2025-66628

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66628 and fix it if it is affected.

What it is: CVE-2025-66628 is a high-severity vulnerability in Imagemagick Imagemagick, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66628 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q16-x86 (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q16-x86 (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q8-AnyCPU (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q8-AnyCPU (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q8-x86 (NuGet): affected all versions; fixed in 14.10.0
- Magick.NET-Q8-x86 (NuGet): affected all versions; fixed in 14.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66628/ (Markdown: https://insights.sbomify.com/CVE-2025-66628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66628
- OSV: https://osv.dev/vulnerability/CVE-2025-66628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66628/
Summaries are generated and may contain mistakes; the official description above is the record.
