# CVE-2025-66630: Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure

> Fiber generates predictable UUIDs when crypto/rand fails, potentially allowing attackers to bypass session, CSRF, or rate-limiting protections.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-68rr-p4fp-j59v, GO-2026-4471

## What is CVE-2025-66630?

CVE-2025-66630 is a critical vulnerability in gofiber fiber, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber is an Express inspired web framework written in Go. Before 2.52.11, on Go versions prior to 1.24, the underlying crypto/rand implementation can return an error if secure randomness cannot be obtained. Because no error is returned by the Fiber v2 UUID functions, application code may unknowingly rely on predictable, repeated, or low-entropy identifiers in security-critical pathways. This is especially impactful because many Fiber v2 middleware components (session middleware, CSRF, rate limiting, request-ID generation, etc.) default to using utils.UUIDv4(). This vulnerability is fixed in 2.52.11.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2025-66630?

4 open source packages ship an affected version, including github.com/gofiber/fiber/v2 and github.com/gofiber/fiber. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.11 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.11 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.11 |
| `github.com/gofiber/fiber` | Go | All versions | None |

Products: Gofiber Fiber.

## How do I fix CVE-2025-66630?

Upgrade github.com/gofiber/fiber/v2 to 2.52.11 or later.

## Is CVE-2025-66630 being exploited?

There is no known exploitation of CVE-2025-66630 in the wild and no public exploit code.

## Other vulnerabilities in gofiber fiber

- [CVE-2024-38513](https://insights.sbomify.com/CVE-2024-38513/): Fiber Session Middleware Token Injection Vulnerability (critical 10.0)
- [CVE-2023-45128](https://insights.sbomify.com/CVE-2023-45128/): CSRF Token Reuse Vulnerability in fiber (critical 10.0)
- [CVE-2024-25124](https://insights.sbomify.com/CVE-2024-25124/): Fiber has Insecure CORS Configuration, Allowing Wildcard Origin with Credentials (critical 9.4)
- [CVE-2025-54801](https://insights.sbomify.com/CVE-2025-54801/): Fiber Susceptible to Crash via `BodyParser` Due to Unvalidated Large Slice Index in Decoder (high 8.7)
- [CVE-2023-45141](https://insights.sbomify.com/CVE-2023-45141/): CSRF Token Validation Vulnerability in fiber (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66630 and fix it if it is affected.

What it is: CVE-2025-66630 is a critical vulnerability in gofiber fiber, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66630 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.11
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.11
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.11
- github.com/gofiber/fiber (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66630/ (Markdown: https://insights.sbomify.com/CVE-2025-66630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66630
- OSV: https://osv.dev/vulnerability/CVE-2025-66630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66630/
Summaries are generated and may contain mistakes; the official description above is the record.
