CVE-2025-66631 CSLA .NET is vulnerable to Remote Code Execution via WcfProxy

High 7.2 Published Updated

Remote code execution via insecure deserialization in WcfProxy allows attackers to execute arbitrary code in applications using CSLA .NET.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-66631?

CVE-2025-66631 is a high-severity unsafe deserialization vulnerability in MarimerLLC csla, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.

Weakness: CWE-502

Which versions are affected by CVE-2025-66631?

2 open source packages ship an affected version, including Csla. It affects 1 product.

PackageAffectedFixed in
Csla NuGetAll versions6.0.0
Csla NuGetAll versions6.0.0

Products include Cslanet Csla .Net.

How do I fix CVE-2025-66631?

Upgrade Csla to 6.0.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-66631 being exploited?

There is no known exploitation of CVE-2025-66631 in the wild and no public exploit code.

Sources

Also known as GHSA-wq34-7f4g-953v.

Is CVE-2025-66631 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free