{"answers":{"affected":"2 open source packages ship an affected version, including Csla. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66631 in the wild and no public exploit code.","fix":"Upgrade Csla to 6.0.0 or later.","what":"CVE-2025-66631 is a high-severity unsafe deserialization vulnerability in MarimerLLC csla, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66631 and fix it if it is affected.\n\nWhat it is: CVE-2025-66631 is a high-severity unsafe deserialization vulnerability in MarimerLLC csla, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-66631 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Csla (NuGet): affected all versions; fixed in 6.0.0\n- Csla (NuGet): affected all versions; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66631/ (Markdown: https://insights.sbomify.com/CVE-2025-66631/index.md)","id":"CVE-2025-66631","markdown":"https://insights.sbomify.com/CVE-2025-66631/index.md","name":"CVE-2025-66631","record":{"aliases":["GHSA-wq34-7f4g-953v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CSLA .NET framework","requires_auth":"none","summary":"Remote code execution via insecure deserialization in WcfProxy allows attackers to execute arbitrary code in applications using CSLA .NET.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"csla_.net","vendor":"cslanet"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSLA .NET is vulnerable to Remote Code Execution via WcfProxy","id":"CVE-2025-66631","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in Affinity","id":"CVE-2025-66633"},"packages":[{"ecosystem":"NuGet","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"Csla","purl":null,"source":"GHSA-wq34-7f4g-953v"},{"ecosystem":"NuGet","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"Csla","purl":"pkg:nuget/Csla","source":"GHSA-wq34-7f4g-953v"}],"prev":{"headline":"Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure","id":"CVE-2025-66630"},"products":["csla"],"published":"2025-12-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["MarimerLLC"]},"summary":"Remote code execution via insecure deserialization in WcfProxy allows attackers to execute arbitrary code in applications using CSLA .NET.","url":"https://insights.sbomify.com/CVE-2025-66631/"}