# CVE-2025-66631: CSLA .NET is vulnerable to Remote Code Execution via WcfProxy

> Remote code execution via insecure deserialization in WcfProxy allows attackers to execute arbitrary code in applications using CSLA .NET.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-wq34-7f4g-953v

## What is CVE-2025-66631?

CVE-2025-66631 is a high-severity unsafe deserialization vulnerability in MarimerLLC csla, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-66631?

2 open source packages ship an affected version, including Csla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Csla` | NuGet | All versions | 6.0.0 |
| `Csla` | NuGet | All versions | 6.0.0 |

Products: Cslanet Csla .Net.

## How do I fix CVE-2025-66631?

Upgrade Csla to 6.0.0 or later.

## Is CVE-2025-66631 being exploited?

There is no known exploitation of CVE-2025-66631 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66631 and fix it if it is affected.

What it is: CVE-2025-66631 is a high-severity unsafe deserialization vulnerability in MarimerLLC csla, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66631 in the wild and no public exploit code.

Affected packages and fixed versions:
- Csla (NuGet): affected all versions; fixed in 6.0.0
- Csla (NuGet): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66631/ (Markdown: https://insights.sbomify.com/CVE-2025-66631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66631
- OSV: https://osv.dev/vulnerability/CVE-2025-66631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66631/
Summaries are generated and may contain mistakes; the official description above is the record.
