{"answers":{"affected":"2 open source packages ship an affected version, including vega-functions. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66648 in the wild and no public exploit code.","fix":"Upgrade vega-functions to 6.1.1 or later.","what":"CVE-2025-66648 is a high-severity cross-site scripting vulnerability in vega, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66648 and fix it if it is affected.\n\nWhat it is: CVE-2025-66648 is a high-severity cross-site scripting vulnerability in vega, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-66648 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vega-functions (npm): affected all versions; fixed in 6.1.1\n- vega-functions (npm): affected all versions; fixed in 6.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66648/ (Markdown: https://insights.sbomify.com/CVE-2025-66648/index.md)","id":"CVE-2025-66648","markdown":"https://insights.sbomify.com/CVE-2025-66648/index.md","name":"CVE-2025-66648","record":{"aliases":["DEBIAN-CVE-2025-66648","GHSA-m9rg-mr6g-75gm","UBUNTU-CVE-2025-66648"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vega functions library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via the setdata function in vega-functions, affecting sites processing untrusted user input.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vega-functions","vendor":"vega-functions_project"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"`vega-functions` vulnerable to Cross-site Scripting via `setdata` function","id":"CVE-2025-66648","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Further research determined the issue is not a vulnerability.","id":"CVE-2025-66649"},"packages":[{"ecosystem":"npm","fixed":["6.1.1"],"introduced":["0"],"last_affected":[],"package":"vega-functions","purl":null,"source":"GHSA-m9rg-mr6g-75gm"},{"ecosystem":"npm","fixed":["6.1.1"],"introduced":["0"],"last_affected":[],"package":"vega-functions","purl":"pkg:npm/vega-functions","source":"GHSA-m9rg-mr6g-75gm"}],"prev":{"headline":"RIOT OS has buffer overflow in gnrc_ipv6_ext_frag_reass","id":"CVE-2025-66647"},"products":["vega"],"published":"2026-01-05","related":[{"cvss_score":6.5,"headline":"Vega `scale` expression function cross site scripting","id":"CVE-2023-26486","kev_date_added":null,"published":"2023-03-03"},{"cvss_score":6.5,"headline":"Vega has cross-site scripting vulnerability in `lassoAppend` function","id":"CVE-2023-26487","kev_date_added":null,"published":"2023-03-03"},{"cvss_score":5.3,"headline":"Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`","id":"CVE-2025-26619","kev_date_added":null,"published":"2025-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-06","vendors":["vega"]},"summary":"Attackers can execute arbitrary JavaScript via the setdata function in vega-functions, affecting sites processing untrusted user input.","url":"https://insights.sbomify.com/CVE-2025-66648/"}