# CVE-2025-66675: Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) - version ranges fixed

> Attackers can cause disk exhaustion and denial of service by exploiting a file leak in Apache Struts multipart request processing.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 10 Dec 2025
- **Also known as:** GHSA-rg58-xhh7-mqjw

## What is CVE-2025-66675?

CVE-2025-66675 is a high-severity denial of service vulnerability in Apache Struts, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.

This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3.

Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

It's related to  https://cve.org/CVERecord?id=CVE-2025-64775  - this CVE addresses missing affected version 6.7.4

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2025-66675?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 6.8.0 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 6.8.0 |
| `org.apache.struts:struts2-core` | Maven | From 7.0.0 | 7.1.1 |
| `org.apache.struts:struts2-core` | Maven | From 7.0.0 | 7.1.1 |

Products: Apache Struts.

## How do I fix CVE-2025-66675?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 6.8.0 or 7.1.1.

## Is CVE-2025-66675 being exploited?

There is no known exploitation of CVE-2025-66675 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66675 and fix it if it is affected.

What it is: CVE-2025-66675 is a high-severity denial of service vulnerability in Apache Struts, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66675 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 6.8.0
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 6.8.0
- org.apache.struts:struts2-core (Maven): affected from 7.0.0; fixed in 7.1.1
- org.apache.struts:struts2-core (Maven): affected from 7.0.0; fixed in 7.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66675/ (Markdown: https://insights.sbomify.com/CVE-2025-66675/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66675
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66675
- OSV: https://osv.dev/vulnerability/CVE-2025-66675

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66675/
Summaries are generated and may contain mistakes; the official description above is the record.
