# CVE-2025-6669: gooaclok819 sublinkX jwt.go hard-coded key

> An attacker can bypass JWT authentication in sublinkX by exploiting a hard-coded cryptographic key, potentially gaining unauthorized access.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jun 2025
- **Updated:** 1 Jul 2025
- **Also known as:** GHSA-gfjv-xv9m-gwx5

## What is CVE-2025-6669?

CVE-2025-6669 is a medium-severity vulnerability in gooaclok819 sublinkX, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in gooaclok819 sublinkX up to 1.8. It has been declared as problematic. This vulnerability affects unknown code of the file middlewares/jwt.go. The manipulation with the input sublink leads to use of hard-coded cryptographic key . The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.9 is able to address this issue. The patch is identified as 778d26aef723daa58df98c8060c43f5bf5d1b10b. It is recommended to upgrade the affected component.

Weakness: CWE-321 (Use of Hard-coded Cryptographic Key), CWE-320

## Which versions are affected by CVE-2025-6669?


## How do I fix CVE-2025-6669?

No fix has been published for CVE-2025-6669 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-6669 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6669 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6669 and fix it if it is affected.

What it is: CVE-2025-6669 is a medium-severity vulnerability in gooaclok819 sublinkX, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6669 exists.

Affected product: gooaclok819 sublinkX. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6669/ (Markdown: https://insights.sbomify.com/CVE-2025-6669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6669
- OSV: https://osv.dev/vulnerability/CVE-2025-6669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6669/
Summaries are generated and may contain mistakes; the official description above is the record.
