# CVE-2025-66843: Grav is vulnerable to Stored XSS through authenticated user-edited content

> Authenticated low-privileged users can inject malicious JavaScript into Grav CMS pages, leading to script execution for other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Dec 2025
- **Updated:** 16 Dec 2025
- **Also known as:** GHSA-mh85-44c2-3m97

## What is CVE-2025-66843?

CVE-2025-66843 is a medium-severity cross-site scripting vulnerability in Getgrav Grav, published on 15 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

grav before v1.7.49.5 has a Stored Cross-Site Scripting (Stored XSS) vulnerability in the page editing functionality. An authenticated low-privileged user with permission to edit content can inject malicious JavaScript payloads into editable fields. The payload is stored on the server and later executed when any other user views or edits the affected page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66843?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions to 1.7.49.5 | None |
| `getgrav/grav` | Packagist | All versions to 1.7.49.5 | None |

Products: Getgrav Grav.

## How do I fix CVE-2025-66843?

No fix has been published for CVE-2025-66843 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66843 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66843 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66843 and fix it if it is affected.

What it is: CVE-2025-66843 is a medium-severity cross-site scripting vulnerability in Getgrav Grav, published on 15 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66843 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions up to 1.7.49.5; no fix listed
- getgrav/grav (Packagist): affected all versions up to 1.7.49.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66843/ (Markdown: https://insights.sbomify.com/CVE-2025-66843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66843
- OSV: https://osv.dev/vulnerability/CVE-2025-66843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66843/
Summaries are generated and may contain mistakes; the official description above is the record.
