CVE-2025-6707 Race condition in privilege cache invalidation cycle

Medium 4.2 Published Updated

An authenticated user may execute actions with stale privileges due to a race condition in cache invalidation, allowing unauthorized access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-6707?

CVE-2025-6707 is a medium-severity vulnerability in Mongodb Mongodb, published on 26 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Under certain conditions, an authenticated user request may execute with stale privileges following an intentional change by an authorized administrator. This issue affects MongoDB Server v5.0 version prior to 5.0.31, MongoDB Server v6.0 version prior to 6.0.24, MongoDB Server v7.0 version prior to 7.0.21 and MongoDB Server v8.0 version prior to 8.0.5.

Weakness: CWE-863

Which versions are affected by CVE-2025-6707?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.31, 6.0.24, 7.0.21, 8.0.5

Products include Mongodb Mongodb.

How do I fix CVE-2025-6707?

Upgrade mongodb to a fixed version for your release line: 5.0.31, 6.0.24, 7.0.21 or 8.0.5.

Is CVE-2025-6707 being exploited?

There is no known exploitation of CVE-2025-6707 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-6707, GHSA-2r62-3h6c-3fgx, MINI-x7r6-m8m6-gjmx, MINI-xj44-3wf8-r853.

Is CVE-2025-6707 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free