CVE-2025-6709 Pre-Authentication Denial of Service Vulnerability in MongoDB Server's OIDC Authentication
Attackers can crash MongoDB Server via malicious JSON payloads during OIDC authentication, requiring OIDC to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6709?
CVE-2025-6709 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 26 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The MongoDB Server is susceptible to a denial of service vulnerability due to improper handling of specific date values in JSON input when using OIDC authentication. This can be reproduced using the mongo shell to send a malicious JSON payload leading to an invariant failure and server crash. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5.
The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.
Weakness: CWE-20
Which versions are affected by CVE-2025-6709?
1 open source package ship an affected version, including mongodb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mongodb Bitnami | From 6.0.0 | 6.0.21, 7.0.17, 8.0.5 |
Products include Mongodb Mongodb.
How do I fix CVE-2025-6709?
Upgrade mongodb to a fixed version for your release line: 6.0.21, 7.0.17 or 8.0.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-6709 being exploited?
There is no known exploitation of CVE-2025-6709 in the wild and no public exploit code.
Other vulnerabilities in Mongodb Mongodb
- CVE-2025-14847 MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency
- CVE-2026-82067 Auth bypass in MongoDB Server
- CVE-2026-13072 MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption
- CVE-2017-15535 Denial of service in n/a
- CVE-2026-18691 Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure
Sources
Also known as BIT-mongodb-2025-6709, GHSA-5cq2-33xv-h4mm, MINI-3fjm-fr3c-hqw5, MINI-mwv7-rj27-725c, UBUNTU-CVE-2025-6709.