CVE-2025-6710 Pre-authentication Denial of Service Stack Overflow Vulnerability in JSON Parsing via Excessive Recursion in MongoDB

High 7.5 Published Updated

Attackers can crash MongoDB Server via crafted JSON inputs causing stack overflow, requiring upgrades to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-6710?

CVE-2025-6710 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 26 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MongoDB Server may be susceptible to stack overflow due to JSON parsing mechanism, where specifically crafted JSON inputs may induce unwarranted levels of recursion, resulting in excessive stack space consumption. Such inputs can lead to a stack overflow that causes the server to crash which could occur pre-authorisation. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5.

The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.

Weakness: CWE-674

Which versions are affected by CVE-2025-6710?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 6.0.06.0.21, 7.0.17, 8.0.5

Products include Mongodb Mongodb.

How do I fix CVE-2025-6710?

Upgrade mongodb to a fixed version for your release line: 6.0.21, 7.0.17 or 8.0.5.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-6710 being exploited?

There is no known exploitation of CVE-2025-6710 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-6710, GHSA-p332-57gq-w6hx, MINI-62qw-f239-r3c4, MINI-9m84-mj32-mwqf, UBUNTU-CVE-2025-6710.

Is CVE-2025-6710 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free