CVE-2025-6711 Incomplete Redaction of Sensitive Information in MongoDB Server Logs
Attackers with log access can view unredacted sensitive queries in MongoDB server logs during error conditions, exposing confidential data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6711?
CVE-2025-6711 is a medium-severity vulnerability in Mongodb Mongodb, published on 7 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been identified in MongoDB Server where unredacted queries may inadvertently appear in server logs when certain error conditions are encountered. This issue affects MongoDB Server v8.0 versions prior to 8.0.5, MongoDB Server v7.0 versions prior to 7.0.18 and MongoDB Server v6.0 versions prior to 6.0.21.
Weakness: CWE-532
Which versions are affected by CVE-2025-6711?
1 open source package ship an affected version, including mongodb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mongodb Bitnami | From 6.0.0 | 6.0.21, 7.0.18, 8.0.5 |
Products include Mongodb Mongodb.
How do I fix CVE-2025-6711?
Upgrade mongodb to a fixed version for your release line: 6.0.21, 7.0.18 or 8.0.5.
Is CVE-2025-6711 being exploited?
There is no known exploitation of CVE-2025-6711 in the wild and no public exploit code.
Other vulnerabilities in Mongodb Mongodb
- CVE-2025-14847 MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency
- CVE-2026-82067 Auth bypass in MongoDB Server
- CVE-2026-13072 MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption
- CVE-2017-15535 Denial of service in n/a
- CVE-2026-18691 Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure
Sources
Also known as BIT-mongodb-2025-6711, GHSA-2844-pfq3-9x4m, MINI-32j8-8j55-vqf5, MINI-83w6-p3wv-wqf6, UBUNTU-CVE-2025-6711.