# CVE-2025-6711: Incomplete Redaction of Sensitive Information in MongoDB Server Logs

> Attackers with log access can view unredacted sensitive queries in MongoDB server logs during error conditions, exposing confidential data.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** BIT-mongodb-2025-6711, GHSA-2844-pfq3-9x4m, MINI-32j8-8j55-vqf5, MINI-83w6-p3wv-wqf6, UBUNTU-CVE-2025-6711

## What is CVE-2025-6711?

CVE-2025-6711 is a medium-severity vulnerability in Mongodb Mongodb, published on 7 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue has been identified in MongoDB Server where unredacted queries may inadvertently appear in server logs when certain error conditions are encountered. This issue affects MongoDB Server v8.0 versions prior to 8.0.5, MongoDB Server v7.0 versions prior to 7.0.18 and MongoDB Server v6.0 versions prior to 6.0.21.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-6711?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 6.0.0 | 6.0.21, 7.0.18, 8.0.5 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-6711?

Upgrade mongodb to a fixed version for your release line: 6.0.21, 7.0.18 or 8.0.5.

## Is CVE-2025-6711 being exploited?

There is no known exploitation of CVE-2025-6711 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6711 and fix it if it is affected.

What it is: CVE-2025-6711 is a medium-severity vulnerability in Mongodb Mongodb, published on 7 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6711 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 6.0.0; fixed in 6.0.21, 7.0.18, 8.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6711/ (Markdown: https://insights.sbomify.com/CVE-2025-6711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6711
- OSV: https://osv.dev/vulnerability/CVE-2025-6711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6711/
Summaries are generated and may contain mistakes; the official description above is the record.
