CVE-2025-6713 MongoDB Server may be susceptible to privilege escalation due to $mergeCursors stage
An unauthorized user can access data without proper authorization by exploiting improper handling of the $mergeCursors stage in MongoDB Server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6713?
CVE-2025-6713 is a high-severity missing authorization vulnerability in Mongodb Mongodb, published on 7 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An unauthorized user may leverage a specially crafted aggregation pipeline to access data without proper authorization due to improper handling of the $mergeCursors stage in MongoDB Server. This may lead to access to data without further authorisation. This issue affects MongoDB Server MongoDB Server v8.0 versions prior to 8.0.7, MongoDB Server v7.0 versions prior to 7.0.19 and MongoDB Server v6.0 versions prior to 6.0.22
Weakness: CWE-285
Which versions are affected by CVE-2025-6713?
1 open source package ship an affected version, including mongodb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mongodb Bitnami | From 6.0.0 | 6.0.22, 7.0.19, 8.0.7 |
Products include Mongodb Mongodb.
How do I fix CVE-2025-6713?
Upgrade mongodb to a fixed version for your release line: 6.0.22, 7.0.19 or 8.0.7.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-6713 being exploited?
There is no known exploitation of CVE-2025-6713 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Mongodb Mongodb
- CVE-2025-14847 MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency
- CVE-2026-82067 Auth bypass in MongoDB Server
- CVE-2026-13072 MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption
- CVE-2017-15535 Denial of service in n/a
- CVE-2026-18691 Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure
Sources
Also known as BIT-mongodb-2025-6713, GHSA-p3jv-2cpc-349v, MINI-c7vx-xh2g-66cg, MINI-rhmq-4944-9h66, UBUNTU-CVE-2025-6713.