# CVE-2025-6713: MongoDB Server may be susceptible to privilege escalation due to $mergeCursors stage

> An unauthorized user can access data without proper authorization by exploiting improper handling of the $mergeCursors stage in MongoDB Server.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 18 Jul 2025
- **Also known as:** BIT-mongodb-2025-6713, GHSA-p3jv-2cpc-349v, MINI-c7vx-xh2g-66cg, MINI-rhmq-4944-9h66, UBUNTU-CVE-2025-6713

## What is CVE-2025-6713?

CVE-2025-6713 is a high-severity missing authorization vulnerability in Mongodb Mongodb, published on 7 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An unauthorized user may leverage a specially crafted aggregation pipeline to access data without proper authorization due to improper handling of the $mergeCursors stage in MongoDB Server. This may lead to access to data without further authorisation. This issue affects MongoDB Server MongoDB Server v8.0 versions prior to 8.0.7, MongoDB Server v7.0 versions prior to 7.0.19 and MongoDB Server v6.0 versions prior to 6.0.22

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-6713?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 6.0.0 | 6.0.22, 7.0.19, 8.0.7 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-6713?

Upgrade mongodb to a fixed version for your release line: 6.0.22, 7.0.19 or 8.0.7.

## Is CVE-2025-6713 being exploited?

There is no known exploitation of CVE-2025-6713 in the wild and no public exploit code.

Public exploit code:

- craft aggregation pipeline to access data without proper authorisation due to improper handling of $mergeCursors in MongoDB >v8.0 <8.0.7, >v7.0 <7.0.19, >v6.0 <6.0.22 (github_poc): https://github.com/c137req/CVE-2025-6713

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6713 and fix it if it is affected.

What it is: CVE-2025-6713 is a high-severity missing authorization vulnerability in Mongodb Mongodb, published on 7 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6713 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 6.0.0; fixed in 6.0.22, 7.0.19, 8.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6713/ (Markdown: https://insights.sbomify.com/CVE-2025-6713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6713
- OSV: https://osv.dev/vulnerability/CVE-2025-6713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6713/
Summaries are generated and may contain mistakes; the official description above is the record.
