CVE-2025-6714 Incorrect Handling of incomplete data may prevent mongoS from Accepting New Connections
Attackers can cause MongoDB mongos to reject new connections by sending incomplete data, requiring load balancer support configuration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6714?
CVE-2025-6714 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MongoDB Server's mongos component can become unresponsive to new connections due to incorrect handling of incomplete data. This affects MongoDB when configured with load balancer support. This issue affects MongoDB Server v6.0 prior to 6.0.23, MongoDB Server v7.0 prior to 7.0.20 and MongoDB Server v8.0 prior to 8.0.9
Required Configuration:
This affects MongoDB sharded clusters when configured with load balancer support for mongos using HAProxy on specified ports.
Which versions are affected by CVE-2025-6714?
1 open source package ship an affected version, including mongodb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mongodb Bitnami | From 6.0.0 | 6.0.23, 7.0.20, 8.0.9 |
Products include Mongodb Mongodb.
How do I fix CVE-2025-6714?
Upgrade mongodb to a fixed version for your release line: 6.0.23, 7.0.20 or 8.0.9.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-6714 being exploited?
There is no known exploitation of CVE-2025-6714 in the wild and no public exploit code.
Other vulnerabilities in Mongodb Mongodb
- CVE-2025-14847 MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency
- CVE-2026-82067 Auth bypass in MongoDB Server
- CVE-2026-13072 MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption
- CVE-2017-15535 Denial of service in n/a
- CVE-2026-18691 Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure
Sources
Also known as BIT-mongodb-2025-6714, GHSA-4cp7-9f6j-9x6f, MINI-4667-mp9v-8qrf, MINI-v9mm-mc56-3q63, UBUNTU-CVE-2025-6714.