{"answers":{"affected":"3 open source packages ship an affected version, including comfyui-manager. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67303 exists.","fix":"Upgrade comfyui-manager to 3.38 or later.","what":"CVE-2025-67303 is a high-severity missing authorization vulnerability in n/a, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-67303 and fix it if it is affected.\n\nWhat it is: CVE-2025-67303 is a high-severity missing authorization vulnerability in n/a, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67303 exists.\n\nAffected packages and fixed versions:\n- comfyui-manager (PyPI): affected all versions; fixed in 3.38\n- comfyui-manager (PyPI): affected all versions; fixed in 3.38\n- comfyui-manager (PyPI): affected all versions; fixed in 3.38\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67303/ (Markdown: https://insights.sbomify.com/CVE-2025-67303/index.md)","id":"CVE-2025-67303","markdown":"https://insights.sbomify.com/CVE-2025-67303/index.md","name":"CVE-2025-67303","record":{"aliases":["GHSA-95pq-hr8p-f5g7","PYSEC-2026-2422"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"ComfyUI Manager plugin","requires_auth":"none","summary":"Remote attackers can manipulate configuration and critical data in ComfyUI-Manager due to insufficiently protected file storage accessible via the web interface.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"comfyui-manager","vendor":"comfy"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-420","name":"Unprotected Alternate Channel"}],"description":"An issue in ComfyUI-Manager prior to version 3.38 allowed remote attackers to potentially manipulate its configuration and critical data. This was due to the application storing its files in an insufficiently protected location that was accessible via the web interface","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-01-09","github_poc":6,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2026-01-09T08:43:10Z","kind":"github_poc","ref":"https://github.com/joker-xiaoyan/CVE-2025-67303","stars":0,"title":"test"},{"date":"2026-01-14T10:22:10Z","kind":"github_poc","ref":"https://github.com/maybe-O/CVE-2025-67303","stars":0,"title":null},{"date":"2026-01-22T08:41:44Z","kind":"github_poc","ref":"https://github.com/ExploreUnknowed/CVE-2025-67303","stars":0,"title":null},{"date":"2026-01-24T08:42:40Z","kind":"github_poc","ref":"https://github.com/materaj2/exploit_cve_2025_67303","stars":0,"title":"Create PoC for CVE-2025-67303"},{"date":"2026-05-13T14:46:40Z","kind":"github_poc","ref":"https://github.com/jcaz2378/ComfyUIrce","stars":0,"title":"Git CVE-2025-67303 payload"},{"date":"2026-09-28T10:09:06Z","kind":"github_poc","ref":"https://github.com/Si13NTTT/CVE-2026-22777","stars":0,"title":"CVE-2026-22777 ComfyUI-Manager CRLF Injection leading to RCE chained with CVE-2025-67303"},{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-67303.yaml","stars":null,"title":"ComfyUI-Manager \u003c 3.38 - Configuration Overwrite"}],"tier":"weaponised"},"has_fix":true,"headline":"ComfyUI-Manager has an Unprotected Alternate Channel (CWE-420)","id":"CVE-2025-67303","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2025-67304"},"packages":[{"ecosystem":"PyPI","fixed":["3.38"],"introduced":["0"],"last_affected":[],"package":"comfyui-manager","purl":null,"source":"GHSA-95pq-hr8p-f5g7"},{"ecosystem":"PyPI","fixed":["3.38"],"introduced":["0"],"last_affected":[],"package":"comfyui-manager","purl":"pkg:pypi/comfyui-manager","source":"GHSA-95pq-hr8p-f5g7"},{"ecosystem":"PyPI","fixed":["3.38"],"introduced":["0"],"last_affected":[],"package":"comfyui-manager","purl":"pkg:pypi/comfyui-manager","source":"PYSEC-2026-2422"}],"prev":{"headline":"An issue in ClasroomIO before v.0.2.6 allows a remote attacker to escalate privileges via the endpoints /api/verify and /rest/v1/profile","id":"CVE-2025-67298"},"products":["n/a"],"published":"2026-01-05","related":[{"cvss_score":7.5,"headline":"ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler","id":"CVE-2026-22777","kev_date_added":null,"published":"2026-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-05","vendors":["n/a"]},"summary":"Remote attackers can manipulate configuration and critical data in ComfyUI-Manager due to insufficiently protected file storage accessible via the web interface.","url":"https://insights.sbomify.com/CVE-2025-67303/"}