# CVE-2025-67303: ComfyUI-Manager has an Unprotected Alternate Channel (CWE-420)

> Remote attackers can manipulate configuration and critical data in ComfyUI-Manager due to insufficiently protected file storage accessible via the web interface.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** GHSA-95pq-hr8p-f5g7, PYSEC-2026-2422

## What is CVE-2025-67303?

CVE-2025-67303 is a high-severity missing authorization vulnerability in n/a, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in ComfyUI-Manager prior to version 3.38 allowed remote attackers to potentially manipulate its configuration and critical data. This was due to the application storing its files in an insufficiently protected location that was accessible via the web interface

Weakness: CWE-420 (Unprotected Alternate Channel)

## Which versions are affected by CVE-2025-67303?

3 open source packages ship an affected version, including comfyui-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `comfyui-manager` | PyPI | All versions | 3.38 |
| `comfyui-manager` | PyPI | All versions | 3.38 |
| `comfyui-manager` | PyPI | All versions | 3.38 |

Products: Comfy Comfyui-Manager.

## How do I fix CVE-2025-67303?

Upgrade comfyui-manager to 3.38 or later.

## Is CVE-2025-67303 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67303 exists.

Public exploit code:

- test (github_poc): https://github.com/joker-xiaoyan/CVE-2025-67303
- https://github.com/maybe-O/CVE-2025-67303 (github_poc): https://github.com/maybe-O/CVE-2025-67303
- https://github.com/ExploreUnknowed/CVE-2025-67303 (github_poc): https://github.com/ExploreUnknowed/CVE-2025-67303
- Create PoC for CVE-2025-67303 (github_poc): https://github.com/materaj2/exploit_cve_2025_67303
- Git CVE-2025-67303 payload (github_poc): https://github.com/jcaz2378/ComfyUIrce
- CVE-2026-22777 ComfyUI-Manager CRLF Injection leading to RCE chained with CVE-2025-67303 (github_poc): https://github.com/Si13NTTT/CVE-2026-22777

## Other vulnerabilities in n/a

- [CVE-2026-22777](https://insights.sbomify.com/CVE-2026-22777/): ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67303 and fix it if it is affected.

What it is: CVE-2025-67303 is a high-severity missing authorization vulnerability in n/a, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67303 exists.

Affected packages and fixed versions:
- comfyui-manager (PyPI): affected all versions; fixed in 3.38
- comfyui-manager (PyPI): affected all versions; fixed in 3.38
- comfyui-manager (PyPI): affected all versions; fixed in 3.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67303/ (Markdown: https://insights.sbomify.com/CVE-2025-67303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67303
- OSV: https://osv.dev/vulnerability/CVE-2025-67303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67303/
Summaries are generated and may contain mistakes; the official description above is the record.
