CVE-2025-67490 Auth0 Next.js SDK has Improper Request Caching Lookup
Simultaneous requests may cause improper token cache lookups, potentially exposing user data or enabling account takeover in Next.js applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67490?
CVE-2025-67490 is a medium-severity vulnerability in nextjs-auth0, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.
Weakness: CWE-863
Which versions are affected by CVE-2025-67490?
4 open source packages ship an affected version, including @auth0/nextjs-auth0. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@auth0/nextjs-auth0 npm | From 4.11.0 | 4.11.2 |
@auth0/nextjs-auth0 npm | From 4.11.0 | 4.11.2 |
@auth0/nextjs-auth0 npm | From 4.12.0 | 4.12.1 |
@auth0/nextjs-auth0 npm | From 4.12.0 | 4.12.1 |
Products include Auth0 Nextjs-Auth0.
How do I fix CVE-2025-67490?
Upgrade @auth0/nextjs-auth0 to a fixed version for your release line: 4.11.2 or 4.12.1.
Is CVE-2025-67490 being exploited?
There is no known exploitation of CVE-2025-67490 in the wild and no public exploit code.
Other vulnerabilities in nextjs-auth0
Sources
Also known as GHSA-wcgj-f865-c7j7.